Voice subnet change breaks phone calling

freepbx
Tags: #<Tag:0x00007f702039d5e0>

(United States) #1

Hello,

We have a working implementation of FreePBX. We are moving devices to our new IP standard. When moving to a new subnet the phones properly registers and gets a dial tone but cannot make any calls to internal extensions or outbound. Inbound also fails.

The firewall on FreePBX is disabled and the freepbx does see the phone register with the new subnet IP. Am I missing something else that needs to be added?


(Matt Brooks) #2

It still sounds networking related. Try following this guide to see if it resolves your issue:
https://wiki.freepbx.org/display/FPG/NAT+Configuration+FreePBX+12"

This guide sorta covers more than NAT, but the way the SIP protocol works is a phone will register, then SIP will tell it which IP address to go to next. It’s possible that the FreePBX box is simply telling it to go to the wrong place, or the network can’t route it to where it is telling the phones to go next.


(Dickson) #3

make sure that the subnet that your phones are using to talk to the PBX (assuming its different ip range than pbx) is in the sip advanced settings section of the Freepbx GUI.
Also, check the NAT settings on your extensions. You may need adjust the value from its current default value, there are 4-5 you can pick from that may help


#4

In Asterisk SIP Settings, General tab, confirm that Local Networks is correctly set. On the pjsip tab, if Local Network is set, confirm that it is correct. If you change any of these settings, you must restart (not just reload) Asterisk.

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
according to extension type, make a failing internal call, then paste the relevant section of the Asterisk log at https://pastebin.freepbx.org and post the link here.


(Aaron) #5

Did you add the new subnet to intetnal networks if you have nat set to no. f you didnt add the new subnet to your intental networks in sip settings this is the issue.

Did you update the new pbx ip in sip settings.

Afterwards do a core restart or fwconsole restart for good measure.


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.