Voice streaming isn't working from any sip accounts to my freePBX server extension accounts

Hello,

I tried android sip sdk sample projects and android sip softphone apps
with my freePBX server extension accounts.
Registering, outgoing call, incoming call and ringing is good working with my freePBX extensions.
But, I can’t getting any voice stream for my freePBX extensions after incoming call accept.
What is problem about this matter. Must i do a setting for my freePBX extensions on freePBX server?
For example, voice streaming good working from my freePBX extension to linphone sip account.
But it isn’t working from any account (linphone or my freePBX extension) to my frrePBX extension.
How is this problem solve? What must I do for this my problem?

Best Regards.

From a recent post of mine . . .

RTP traffic can easily be seen with

rtp set debug on

more specifically with

rtp set debug ip n.n.n.n

you can easily see the flows (or lack of) for both tx and rx by ip of all participating sessions, arranging correct forwarding and routing will usually fix lack of audio, this usually needs agreement of both asterisk and your networks points of egress and ingress for said routes.

understanding your edge routers implementation of ‘nat’ is important

https://dh2i.com/kbs/kbs-2961448-understanding-different-nat-types-and-hole-punching/

commonly active “sip helpers/ALG’s” on the router can disrupt proper forwarding if you have more than one devices in your LAN needing connectivity

Thanks for your reply. Ok, I will look to rtp traffic for this.
Best Regards.

1 Like

Dear dicko,

I tried rtp trafffic debug for my freePBX extensions calls and I got this result for this.

-- PJSIP/1000000002-0000726b is ringing
   > 0x7f3488e7d280 -- Strict RTP learning after remote address set to: 212.252.118.73:8264
-- PJSIP/1000000002-0000726b answered PJSIP/1000000001-0000726a
   > 0x7f34874c3290 -- Strict RTP learning after remote address set to: 212.252.118.73:8340
-- Channel PJSIP/1000000002-0000726b joined 'simple_bridge' basic-bridge <16e06dc0-497b-4fc7-905b-eef9a7a3fbaa>
-- Channel PJSIP/1000000001-0000726a joined 'simple_bridge' basic-bridge <16e06dc0-497b-4fc7-905b-eef9a7a3fbaa>
[2022-03-02 01:38:36] WARNING[10405][C-00007e61]: res_rtp_asterisk.c:7551 ast_rtp_read: RTP Read too short
[2022-03-02 01:38:36] WARNING[10405][C-00007e61]: res_rtp_asterisk.c:7551 ast_rtp_read: RTP Read too short
[2022-03-02 01:38:36] WARNING[10401][C-00007e61]: res_rtp_asterisk.c:7551 ast_rtp_read: RTP Read too short
[2022-03-02 01:38:36] WARNING[10401][C-00007e61]: res_rtp_asterisk.c:7551 ast_rtp_read: RTP Read too short
   > 0x7f3488e7d280 -- Strict RTP qualifying stream type: audio
   > 0x7f34874c3290 -- Strict RTP qualifying stream type: audio
[2022-03-02 01:38:40] WARNING[1897]: channel.c:5686 set_format: Unable to find a codec translation path: (speex16) -> (ulaw)
[2022-03-02 01:38:40] WARNING[1897]: channel.c:5686 set_format: Unable to find a codec translation path: (ulaw) -> (speex16)
   > 0x7f34874c3290 -- Strict RTP learning after remote address set to: 192.168.1.20:8340
[2022-03-02 01:38:40] WARNING[1897]: channel.c:5686 set_format: Unable to find a codec translation path: (speex16) -> (ulaw)
[2022-03-02 01:38:40] WARNING[1897]: channel.c:5686 set_format: Unable to find a codec translation path: (ulaw) -> (speex16)
   > 0x7f3488e7d280 -- Strict RTP learning after remote address set to: 192.168.1.21:8264
[2022-03-02 01:38:46] WARNING[14497]: res_pjsip_registrar.c:1104 registrar_on_rx_request: Endpoint 'anonymous' (20.115.126.57:51220) has no configured AORs
[2022-03-02 01:39:01] WARNING[14497]: res_pjsip_registrar.c:1104 registrar_on_rx_request: Endpoint 'anonymous' (20.115.126.57:63830) has no configured AORs
[2022-03-02 01:39:10] NOTICE[17497]: res_pjsip_sdp_rtp.c:149 rtp_check_timeout: Disconnecting channel 'PJSIP/1000000001-0000726a' for lack of audio RTP activity in 31 seconds
-- Channel PJSIP/1000000001-0000726a left 'simple_bridge' basic-bridge <16e06dc0-497b-4fc7-905b-eef9a7a3fbaa>
== Spawn extension (macro-dial-one, s, 56) exited non-zero on 'PJSIP/1000000001-0000726a' in macro 'dial-one'
== Spawn extension (macro-exten-vm, s, 30) exited non-zero on 'PJSIP/1000000001-0000726a' in macro 'exten-vm'
== Spawn extension (ext-local, 1000000002, 3) exited non-zero on 'PJSIP/1000000001-0000726a'
-- Executing [[email protected]:1] Macro("PJSIP/1000000001-0000726a", "hangupcall,") in new stack
-- Executing [[email protected]:1] GotoIf("PJSIP/1000000001-0000726a", "1?theend") in new stack
-- Goto (macro-hangupcall,s,3)
-- Channel PJSIP/1000000002-0000726b left 'simple_bridge' basic-bridge <16e06dc0-497b-4fc7-905b-eef9a7a3fbaa>
-- Executing [[email protected]:3] ExecIf("PJSIP/1000000001-0000726a", "0?Set(CDR(recordingfile)=)") in new stack
-- Executing [[email protected]:4] Hangup("PJSIP/1000000001-0000726a", "") in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on 'PJSIP/1000000001-0000726a' in macro 'hangupcall'
== Spawn extension (ext-local, h, 1) exited non-zero on 'PJSIP/1000000001-0000726a'
[2022-03-02 01:39:16] WARNING[14497]: res_pjsip_registrar.c:1104 registrar_on_rx_request: Endpoint 'anonymous' (20.115.126.57:60993) has no configured AORs
freepbx*CLI>

Before any media can flow there must be a mutually agreed codec by both legs. I would suggest your client not solely offer speex16, stick with ulaw on both as a starter, actually as one end is apparently in Turkey, add alaw also to the mix.

1 Like

Dear dicko, Thanks a lot for your precious replies.
All codecs are checked for Audio Codecs on Asterisk SIP Settings.
I cleared checks for all codecs and I checked only ulaw and alaw now.
Is ok now? Is there another change for me? I will try again for this.

You will have to similarly enable agreeable codecs on your client also, Let us know how that works out.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.