Voice mail press "#" = "I'm sorry an error has occurred"


This is a new install of the distro, on all voicemail, they all seem to take messages, however if pressing “#” at the end it says “i’m sorry an error has occurred”.

I am assuming something was missed (or changed) in the default setup, whats supposed to happen after the # key is pressed.

Many Thanks

Check your /var/log/asterisk/full log and look for the playing of that wave file. The error should be right above it.

Thanks, will check in to this…

Well, its fixed, however no idea what the problem was…

Original settings were PJSIP port 5060 with softphone (3CX), GrandStream softphone on an iPad and a Grandstream GXV3240, all with the same problem.

I changed all the ports over (5060 now is CHAN SIP), deleted and re-created all the extensions (same numbers and passwords), all the phones re-logged in (as to them nothing change).

Now the voicemail fully works.

So was this a PJSIP issue inside freePBX?

I know this is an older message but I wanted to offer a solution:
This error plays when the message is less than the minimum number of seconds set within the voicemail admin when the “#” key is pressed.

Under Settings -> Voicemail Admin -> Settings, you’ll want to make sure that “minsecs” - also called Min Message Length (Seconds) - isn’t less than the length of the message before hitting “#”

When changing the minsecs setting, ensure that it is greater than the “maxsilence” - also called Max Message Silence (Milliseconds) - setting to avoid empty messages

1 Like