VMX to Misc Application doesnt work- How to send VMX to Main IVR?

I am trying to use the VMX locator to send calls back to the main IVR so callers can pick another option, or enter a different extension.

I assigned extension 415 to the IVR using Misc Applications.
Then went to my VMX locator settings, and put 415 in the option 1 field.

When I call into my vmail and press 1 it does nothing, just continues playing the greeting, if I press 0 it does go to the operator group.

Is there a more correct procedure to do this?

The voicemail operation is a hardcoded inside asterisk directly and out of the control of FreePBX. So there is not a easy way to change anything around it unless you want to customize the C code in asterisk.

How are you calling into your voicemail. VmX is only going to ‘hijack’ the voicemail system if you flow into the voicemail as a call would come into the system. You can’t even dial * because that hits a ‘DIRECTDIAL’ path which bypasses the VmX system. Try calling in from outside, it should then work.

I am calling in from the outside - I hit the main IVR, then press my extension (ie 400), and I hear the prompt that has been recorded for the VMX Locator “Unavailable” status, I press 1 which should go to a Misc App (called x413) which should bring up the Main IVR again.

This has been a long time request of a couple of clients saying their old pos pbx they had before allowed people to back out of vmail, and yet this doesnt. Now I am leaving town, and get the idea, I suspect most people wont want to leave a message, but would prefer to get back to the main menu where they can pick a better choice.

As a work-around- I tried using a ring group instead, which would play “One moment please”, then ring an extension for 1 second, then Final Dest to the Main IVR. I put the ring group ext in the option 1 field - but again no luck. As a last resort, I also tried a follow-me extension which did a Final Dest to the IVR, but no response.

If I press 0 it goes right to the operator like it should.

So getting more curious - i entered another extension on the system for my VMX option 2, but it does not go there, just continues to play my message, and then plays the “please leave your message after the tone…” - which I also have set to not play in my VMX settings. So VMX doesnt seem to work.

I am running Asterisk 1.2.16 and FreePBX - is this not compatible with VMX?? I dont want to upgrade my asterisk as it has been rock solid.