VMX Locator Looping Voicemail Greeting

I am having a problem that when I enable VMX Locator for an extension to be able to give the user an option to return to the Queue. Basically when I enable the VMX Locator it plays the greeting twice before it beeps to record. Once I uncheck unavailable it plays once but does not give let the user push a button to go back to the queue. Any ideas?

I’m having the exact same issue. Has anyone found a fix for this yet?

FreePBX versions???

I am using FreePBX 12.0.13

Same here, 12.0.13 on asterisk 12

Can you downgrade to Asterisk 11. Asterisk 12 and 13 both have lots of hidden “bugs”

I too am having the same issue, same version of Asterisk. Tried apply a couple weeks of updates today, no change in behavior.

There are no bug reports for this so no one has worked on it.

I had the same thing, its an easy fix.

Settings → Voicemail Admin → Dialplan Behavior → Times to Play Message, change that to 1 attempts. That should take care of your issue.

dslauter, thanks. Unfortunately, this is how mine is already configured.

I can open a bug report, but figured there might be something dumb I’m missing like dslauter pointed out. Unfortunately at this point the VMX Locator’s not working at all, all phones now say “xxx is on the phone” even when they’re not. Something I tinkered with yesterday apparently.

Scratch that. I changed the default direct dial to “unavailable” and now it seems to be working fine. This morning I also changed from 1 attempt to 2, saved it, then changed it back. Between all of this it’s now working properly. Thank you.

1 Like

Glad you were able to figure it out @kenw sounds like something wasn’t saving correctly when the configuration was applied.