VmX Locater plays standard instructions & does not show in ARI

I’m having a problem with the VmX locater. I’m using Trixbox and FreePBX

I’m trying to setup voicemail & VmX in this way

However, when I navigate to the recordings section, and log in, VmX Locater is not shown as a menu item. Additionally, the followme page only has an “update” button on it. Neither of these are a problem really, as my end users do not need to edit their own settings. So I’ve setup the VmX settings on the FreePBX extension editing page. I’m sure that won’t be the problem.

The first real problem I have is that “Voicemail Instructions: [] Standard voicemail prompts” is unchecked, but when the caller holds on the line they get the standard voicemail instructions anyway. Also, in FreePBX General Settings, “Timeout VM Msg,” “Max Loop VM Msg” and “Direct VM Option” are all set to “Beep Only.” I do not want them to get the voicemail instructions - how do I disable them or is this a bug?

Another problem is that I have entered a mobile number for option 2. I would like to have “confirm calls” enabled when this is used. Where should this be set?

I would also prefer to have the options the other way around, so that by default the user is sent to the follow me, or pressing 1 sends them to voicemail. Is that possible?

I have posted up a log of the call where this happens