VM's are not sending to email Email debug works fine


(Kalapacs) #1

We purchased the email GUI app we setup the email sever and using debug we can send emails just fine. We have extensions with voicemail enabled and to send attachment that need to have their messages sent to an email address. According to the Debug log there is no attempt to send an email when there is a new messge in one the extensions. We are using FreePBX 14 (postfix) and when I use the tail command “tail /var/log/maillog” it only shows the test messages that were sent but no new entry for email for actual voicemails.


(Sergio Lobera) #2

Hi !
Are you enabling email address on the extensions ? (Applications > Extensions > Edit your extension > Voicemail Tab

When you leave a voicemail, can you see that voicemail calling to *98 ?


(Kalapacs) #4

Yes I can see the VM’s populate in UCP.


(Sergio Lobera) #5

The only thing I can imagine is that the email is not enabled on your extensions.


(Kalapacs) #6


(Sergio Lobera) #7

is this out distro or just FreePBX software ?
What do you see under Settings > Voicemail Admin > Settings > Email Config ?


(Kalapacs) #8

The footer is FreePBX Sangoma Logo. I also updated from 14 to FreePBX 15.0.16.61 last night.


(Lorne Gaetz) #9

You have a custom script handling your voicemail email which is probably not working. Remove the value in ‘Mail Command’, submit, apply config and retest.


(Kalapacs) #10

This solved my issue. Thanks!! Not sure where it came from never modified settings in there.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.