VM to email issue after 13 to 15 upgrade

This was working prior to the upgrade. Now it’s not. Sanitized sample from maillog. I do not understand why it’s still trying to send from [email protected] when that is NOT what’s configured in Sys Admin Pro.

Dec 9 21:21:38 freepbx postfix/master[50388]: daemon started – version 2.10.1, configuration /etc/postfix
Dec 9 21:34:22 freepbx postfix/pickup[50389]: 23D84C256B96: uid=995 from=
Dec 9 21:34:22 freepbx postfix/cleanup[57985]: 23D84C256B96: message-id=[email protected]
Dec 9 21:34:22 freepbx postfix/qmgr[50390]: 23D84C256B96: from=[email protected], size=140260, nrcpt=1 (queue active)
Dec 9 21:34:22 freepbx postfix/smtp[57995]: 23D84C256B96: to=[email protected], relay=mail.fakedomain.com[10.74.1.246]:587$
Dec 9 21:34:22 freepbx postfix/cleanup[57985]: 5D925C256B97: message-id=[email protected]
Dec 9 21:34:22 freepbx postfix/qmgr[50390]: 5D925C256B97: from=<>, size=2719, nrcpt=1 (queue active)
Dec 9 21:34:22 freepbx postfix/bounce[58006]: 23D84C256B96: sender non-delivery notification: 5D925C256B97
Dec 9 21:34:22 freepbx postfix/qmgr[50390]: 23D84C256B96: removed
Dec 9 21:34:22 freepbx postfix/local[58007]: 5D925C256B97: to=[email protected], relay=local, delay=0.01, delays=0/0.01/0/$
Dec 9 21:34:22 freepbx postfix/qmgr[50390]: 5D925C256B97: removed

You need to have postfix rewrite the from email address using the /etc/postfix/generic file. In general, I add the below to my generic file:

root [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
asterisk [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]

where [email protected] is the email address you wish the emails to come from, and full.fqdn.com is your server’s full hostname.

Also take a look at the voicemail admin settings to make sure the serveremail field is set properly.

I’ve not had to use rewrite rules like this with FreePBX in many years, and in this case it fixed the problem. Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.