VM BLF hints not working - odd quotes around "default"

Hello!

This is a new install of the FreePBX distro. I have two virtual extensions to use as “general” mailboxes. I also have one phone with a BLF for a mailbox assigned to another phone.

It looks like it’s trying to create the hints, but the phones (Polycom VVX410) don’t correctly display the BLF status. I think it might be because the hints aren’t being generated correctly.

Hints in core show hints (related to MWI) look like this:

_*[email protected] : MWI:${EXTEN:3}@${DB( State:Unavailable Presence: Watchers 0 *[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 2

The “default” seems like (based upon the wiki and other forum articles) it should NOT have quotes around it.

I’ve gone as far as rebooting the machine and phones to no avail.

Hopefully this provides the pertinent system info:
FW Console - FreePBX Utility version 13.0.91
PBX Firmware: 10.13.66-9
PBX Service Pack: 1.0.0.0

Thanks!

Please go back to these devices and make sure “default” is not in the gui. It should say [email protected] Not [email protected]“default”

Hi Andrew. I checked the 501 (virtual), 502 (virtual), and 700 (sip) extensions and the VM Context on all just says default (no quotes, see picture). I assume this is what you were referring to.

Also, if I make other changes and click apply config, they change to the following (totally missing anything after the @):

*[email protected] : MWI:[email protected] State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected] State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected] State:Unavailable Presence:not_set Watchers 2

Not sure if that helps any.

Are you in users and devices mode?

In Advanced Settings, User & Devices Mode is set to extensions.

I updated the system to 10.13.66-10 tonight, and rebooted for good measure.

After reboot the only MWI hint listed was:
_*[email protected] : MWI:${EXTEN:3}@${DB( State:Unavailable Presence: Watchers 0

So, I rebooted all the phones. Once the phones came back online this showed:
-- Registered SIP '700' at [removed ip address]:44612 -- Added extension '*98501' priority -1 to app-dialvm -- Added extension '*98502' priority -1 to app-dialvm -- Registered SIP '755' at [removed ip address]:33327 -- Added extension '*98700' priority -1 to app-dialvm

Checking the hints and they’re now back with the @“default”:
*[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 1 *[email protected] : MWI:[email protected]"default" State:Unavailable Presence:not_set Watchers 2

And they’re still not working. :frowning:

Just adding myself to this topic. Same symptoms and checked the settings mentioned and are the same as ris2 with the exception that mine is saying [email protected], [email protected], etc. instead of @default in extensions.

10.13.66-6 to start and also updated to latest with no change. Using PJSIP if that helps. All phones are Cisco. No virtual extensions here.

“device” or device. There’s a difference.

reads @device

No quotes

Here is a snip for confirmation.

You aren’t looking at the same place

Go to asterisk -rvvvv.

Run: “core show hints”

Read the first post in this thread.

This is the full output of core show hints

`
-= Registered Asterisk Dial Plan Hints =-
27[email protected]: State:Unavailable Presence:not_set Watchers 0
*[email protected] : park:[email protected]& State:Unavailable Presence:not_set Watchers 0
[email protected] : SIP/1001&Custom:DND1 State:Idle Presence: Watchers 0
*[email protected]: Custom:DEVDND1001 State:Unavailable Presence:not_set Watchers 0
_*98X.@app-dialvm : MWI:${EXTEN:3}@${DB( State:Unavailable Presence: Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Unavailable Presence:not_set Watchers 0
_*21X.@ext-findmefol: Custom:FOLLOWME${EXT State:Unavailable Presence: Watchers 0
*[email protected] : Custom:PARK1001 State:Unavailable Presence:not_set Watchers 0
*[email protected]: Custom:DEVCF1001 State:Unavailable Presence:not_set Watchers 0
_*76X.@ext-dnd-hints: Custom:DEVDND${EXTEN State:Unavailable Presence: Watchers 0
_*96X.@ext-cf-hints : Custom:DEVCF${EXTEN: State:Unavailable Presence: Watchers 0
*[email protected] : park:[email protected]& State:Unavailable Presence:not_set Watchers 0
*[email protected] : SIP/1001&Custom:DND1 State:Idle Presence: Watchers 0

  • 20 hints registered`

Your phone isn’t subscribed to any voicemail hint. This is a different issue than this thread. If it was you’d see “*98[num]@” in that list. You don’t there is only the dynamic hint.

Thank you for your help, I apologize for jumping on this thread then, I thought it was the same issue. I will start my own as I will still need some assistance tracking down why the phone isn’t subscribing.

Any thoughts on my weird “default” issue?

There’s an issue yeah. Seems to be related to: http://issues.freepbx.org/browse/FREEPBX-11223

Ah, yep. Sounds exactly the same as mine (mostly).

When I reboot, I have no MWI hints.

If I then reboot the phone, I get the MWI:[ext]@“default” hint.

Then if I ever apply config (or fwconsole restart), they change to MWI:[ext]@

This happens with both virtual and CHAN_SIP extensions.

This is true. the hints are dynamic. The phone needs to ask for them. When you reboot the phone doesnt know you rebooted the PBX

That makes sense. Wasn’t aware so was putting it out there for completeness. Thx!