Viking EP-10-IP Doorbox


(Gabosch) #1

I’ve done quite a bit of digging but I have yet to find any solid information on how to make a Viking EP-10-IP doorbox work with a Sangoma PBXact 60 running Asterisk 17.9.1 and FreePBX 15.0.17.12. According to Viking, all you need to do is enter the SIP server, the extension and the password (I assume it’s the secret password), and the doorbox will register. Not that case for me.

I included the VIking’s MAC address in the extension’s advanced settings, and am using port 5060 for the doorbox extension even though all my other extensions are pjsip. There is a field in the SIP Server setup in the Viking for the Authentication ID, but I don’t know what it’s asking for there.

What am I doing wrong?


#2

Some devices won’t accept the long default passwords autogenerated by FreePBX.

Set the Secret for the extension to something simple, no more than 12 letters and digits. Copy/paste that to the Doorbox. Set Authentication ID in the Doorbox to the extension number.

Defaults are 5060 for pjsip and 5160 for chan_sip. Are you saying that you changed these around and then used a chan_sip extension for Doorbox? Though I don’t see a problem with that, why?


(Gabosch) #3

Thanks for answering. Yes, I changed them around. All my managed systems are set for PJSIP at 5160; have been for a while. I want the consistency.


(Gabosch) #4

Stewart, you’re a genius. UI used a shorter password and it registered right away. Thank you!


(Lorne Gaetz) #5

Note that the auto generated SIP secret length is configurable in Advanced Settings if you need to adjust.


(Gabosch) #6

Thanks, Lorne.