Vega Module Transport Error

When trying to discover a Vega 60 FXO or FXS gateway within FreePBX Vega Management module the discovery returns no results. Trying to manually add a vega gateway fails as well.

It fails with message “Failed to connect to ssh://admin:[email protected]:22, transport not supported”

Vega Gateway Module log contains the same error as above.

Both the gateway and FreePBX instance are on the same subnet. I’ve tried entering the correct subnet info and trying to discovery the gateway, I’ve also tried to directly add the gateway in FreePBX. In both cases, I’ve tried the default gateway credentials of admin/admin and I’ve tried creating a new password on the gateway first, then trying to discover/add it. - Doesn’t give any different results.

Also tried the latest gateway GA versions 11 and 12

All results in the same transport error.

From the FreePBX instance, I can ping the gateways and ssh into them as well.

Current PBX Version:
Current System Version:12.7.4-1804-1.sng7
Python 2.7.5 (default, Aug 4 2017, 00:39:18)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-16)] on linux2

Looking in the source code, I can find the “transport error” output line but I don’t know python well enough to troubleshoot further. Has anybody else seen this before?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.