Vega gateway calls not acepted by freepbx


(Joseph Helou) #1

Hello Community,
i tried to navigate the snake and ladder system of Sangoma’s paid support but they have apparently hired the best evasion artists to make it impossible for their customers to get support directly from them.

i have a Vega100G gateway that is used to interface a PRI line with Freepbx. the configuration is make without registration.
here is the trunk configuration on the freepbx side:

Outgoing:
username=user
type=peer
secret=pass
qualify=yes
host=XXXXXXXX
fromuser=user

Incoming:
type=peer
qualify=yes
host=XXXXXXXX
context=from-trunk

the outgoing calls work well from Freepbx through the Vega
the incoming calls however get blocked by Freepbx with the following message:
handle_request_invite: Failed to authenticate device user@freepbxip

Any help would be greatly appreciated.

Thank you


#2

Try:

Outgoing:
username=user
type=peer
secret=pass
qualify=yes
host=XXXXXXXX
fromuser=user
insecure=port,invite
context=from-trunk

Incoming:
(leave blank)


(Joseph Helou) #3

Thank you for the reply. would i need to allow guest SIP calls coming in? i must schedule the test for evenings since the PRI line is currently used with an analog production system. I am trying to gather the most number of suggestions to run all possibilities in one batch.

Thank you


#4

You don’t need to allow guest, but you should set up a catch-all Inbound Route (DID Number and CallerID Number both left blank), so if the called number is not transmitted as expected, the call will come in and the CDR will show what was sent. You can then adjust routes accordingly.


(Joseph Helou) #5

neither helped. it must have something to do with how the vega is sending the call to Freepbx. i cannot find a single valid tutorial online for something as straight forward as using it as an SIP gateway with Freepbx! Way to go Sangoma…


#6

I went thru a few hours of paid support after using the Vega config module on a brand new system. Unfortunately, the module is unequivocally broken. I’m not exactly sure what they did to get it to work…I think Jack is the only Vega guy at this point. but I can tell you that the latest issue was a clipping of the first digit of the inbound CID. “auto” on the Vega apparently doesn’t work on North American NI2. Make sure you’re setting that.


(Joseph Helou) #7

i hear you, i had a similar issue with another vega that i purchased, they connected and fixed it somehow but i can’t remember what they did. it was 5 years ago. Sangoma is definitely milking these systems through inevitable after-sale support and absolutely no documentation… i am down to packet analysis at this point. it looks like there is something about the vega sending registration info even though it is operating without registration. i’ll keep banging at it, will post what i find here.


(Joseph Helou) #8

so the answer was pretty simple at the end. i was missing the following from the incoming settings:
insecure=very

the working configuration is:

Outgoing:
username=user
type=peer
secret=pass
qualify=yes
host=XXXXXXXX
fromuser=user
insecure=port,invite
context=from-trunk

Incoming:
type=peer
qualify=yes
host=XXXXXXX
context=from-trunk
allow=all
insecure=very

Thank you everyone who tried to help with this.


(Lorne Gaetz) #9

I’m surprised that very is still valid. The correct way of setting this has long been:

insecure=port,invite

source: https://github.com/asterisk/asterisk/blob/master/configs/samples/sip.conf.sample#L1566


(Joseph Helou) #10

it did not seem to work with port,invite
also all my bookmarks for vega configuration are now broken links and no new basic instructions exist. These forums i find are the best knowledge base that exists out there.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.