v3 installation

hi, just downloaded v3 and tried the web-installer. based on ur instructions i created a folder /usr/local/freeswitch and a subfolder conf
drwxrwsrwx 3 www-data www-data 4096 2009-08-04 22:01 freeswitch
and gave recursive permissions to my apache-“user”. but the installer tells me:
Telephony Engine
Modular Telephony Software Framework and Application
Unable to write to

* /usr/local/freeswitch/conf/directory/default.xml
* /usr/local/freeswitch/conf/sip_profiles/freepbx_trunk_groups.xml
* /usr/local/freeswitch/conf/dialplan/freepbx_dialplan.xml
* /usr/local/freeswitch/conf/autoload_configs/conference.conf.xml
* /usr/local/freeswitch/conf/autoload_configs/ivr.conf.xml

any ideas?



mkdir /usr/local/freeswitch/conf/directory
mkdir /usr/local/freeswitch/conf/sip_profiles
mkdir /usr/local/freeswitch/conf/dialplan
mkdir /usr/local/freeswitch/conf/autoload_configs

And it will work, don’t forget to set permissions

installation successfull - very coold design!

under the hood i have a fresh install of asterisk 1.6.1, but somehow i cant register phones anymore (all testenvironment).

after starting asterisk from the cli i get:

Could not load features.conf
== Registered application ‘ParkedCall’
== Registered application ‘Park’
== Manager registered action ParkedCalls
== Manager registered action Park
== Manager registered action Bridge
== Manager registered action DBGet
== Manager registered action DBPut
== Manager registered action DBDel
== Manager registered action DBDelTree
Asterisk Dynamic Loader Starting:
No ‘modules.conf’ found, no modules will be loaded.

do i ahve to do any adjustments?

Warning Message

An error was detected which prevented the loading of this page. If this problem persists, please contact the website administrator.

modules/esl/assets/ESL.php [23]:

dl() [function.dl]: Dynamically loaded extensions aren’t enabled
Stack Trace

* modules/esl/assets/ESL.php [23]:

  dl(  )

* modules/esl/libraries/EslManager.php [3]:

  include(  )

* system/core/Kohana.php [981]:

  require(  )


  Kohana::auto_load(  )

* modules/voicemail/libraries/VoicemailManager.php [389]:

  spl_autoload_call(  )

* modules/voicemail/libraries/VoicemailManager.php [346]:

  VoicemailManager::MessageCount(  )

* modules/voicemail/controllers/voicemail.php [87]:

  VoicemailManager::updateMWI(  )


  Voicemail_Controller->index(  )

* system/core/Kohana.php [270]:

  ReflectionMethod->invokeArgs(  )


  Kohana::instance(  )

* system/core/Event.php [209]:

  call_user_func(  )

* system/core/Bootstrap.php [55]:

  Event::run(  )

* index.php [102]:

  require(  )

Loaded in 0.3602 seconds, using 7.65MB of memory. Generated by Kohana v2.3.1.

We’re trying to make that error a bit friendlier, but the issue is you need the ESL library provided by FreeSWITCH to use the voicemail plug-in. Sorry the error is not clean :frowning:

FreeSWITCH (and I think Asterisk) both require fancy footwork to query a database or otherwise to get voicemail messages, and to turn on/off message lights when a message is deleted. Since we allow for management of voicemail from the UI, we need this access, and hence, we need ESL.

Does this help?

http://wiki.freeswitch.org/wiki/Event_Socket_Library for info on installing FreeSWITCH’s ESL library.

  • upgrade v3 again, re-run the installation wizard and as driver there was only “freeswitch” in there - ok, coz i installed freeswitch and its running.
  • so, i registered myself on the v3-index-website, but am i admin now?
  • how do i actually connect my test-softphone to it?
    thx in advance
    i appreciate it

I am very new to this and need to know if freepbx must be run on a dedicated computer or can I run it on my windows vista computer concurrently with everything else I have on it. Thanks for your help in this matter as I really don’t want to have to install it on a dedicated computer.

this. general rule:
productive system > dedicated machine!
test > ok to run several things on the same machine as long as the ports dont block each other…

I am building one from a base CentOS 5.3 VPS. The instructions say to just remove the _64 (if you are 32bit) and use:

Which borks on the mysql-x stuff. To get past this I used:


I’ll see if this pans out before adding it to the wiki.

I have the same problem. In fact, the directories exist (so “redoing” them won’t change anything).
I changed group to apache and chmod to g+w as explained in the installation manual.

The same error occurs. The install script can read in the directories as it sees if the files to be over written exist (default.xml for example).
So I’m really stuck…

Do you have any ideas?