v2.10.0.0 Unable to change network settings in System Admin > Network Settings

I am currently using FreePBX-Distro-Net-32bit-

After installation, I attempted to change network settings using System Admin > Network Settings in FreePBX v2.10.0.0.

I received the following prompts:

Please wait while we process your request.

An error has occured. Please try again.

This is for any change I attempt to make. I have attempted modifying the ip, subnet and gateway, and also attempted turning DHCP on.

Can you verify incrond is running. do a service incrond status

“incrond (pid 3032) is running…”

try restarting the service and see if that fixes it. Also what version of the Distro are you using?

I am currently using FreePBX-Distro-Net-32bit-

I restarted the incrond service and I’m still receiving the error. I have also manually edited the addresses without success.

I don’t think this is related, but I am behind an untangle firewall and can’t connect to any sip devices. Please don’t let it muddle this support issue but could that be related?

Is there a recommended stable version of Distro? Or is this it?

I tried connecting a sip device, internally, without success.

That is the stable release. Sounds like you have a network issue.

I fixed the firewall issue. I still cannot edit from the System Admin module.

Is there any suggestions? Can the issue be replicated?

I have a suggestion, and I know how to fix it but you are going to toss bricks at me.

Take the silly feature out of the module. Set the IP info from the command line. You are just going to have to drop down to it anyway to run ping and traceroutes to test your network.

I configured it via command line. The problem is I’m still not able to connect a local sip client and I think the issue is related for some reason. I’m going to reinstall. I think something hiccup’d.