V14 - Ring group missed calls notification keeps failing


On the only ring group, I got the Ring Strategy set for “ringall” and Mark Answered Elsewhere set to NO.

All the extensions in the ring group are confirmed to have missed call notifications set to enabled.

After a period of time (unknown how long), the notification of a missed call will stop appearing on all the extensions on the ring group. This can be usually resolved by doing a “fwconsole reload,” but then again will fail after some time passes.

These are remote extensions. The connection between them and the PBX appears to be good as seen with MTR, except for the occasional high ping which comes up.

Any ideas on this?


Sorry, I was thinking it was FreePBX 13, but is version 14. with Asterisk 13.29.2 running

Are these connecting via Chan-SIP or PJ-SIP? One of the limitations of Chan-SIP is that it doesn’t always recover cleanly once you get a network error. It could be that Chan-SIP is just losing it’s mind.

It is chan SIP. . I wonder if changing to PSJIP would help.

I have connected another extension in another remote network to see if it will be afflicted also.
Also went ahead and updated to newest version of Asterisk 13.

Thanks for taking the time to respond.

To be honest, I’ve been slow to come to the party on PJ-SIP. I tried it early on and it wasn’t ready and it left a bad taste in my mouth. Kind of the same way that early Linux (from the early 1990s) did.

In spite of that, if you have the least compelling reason at all to try it, I recommend switching over to PJ-SIP. Over than past four or five years, it’s grown to the point that it really does seem to have the tools and horsepower necessary to replace Chan-SIP in all but the most arcane situation. There’s a thread on the forums right now about a SIP conversion tool for extensions, and Chan-SIP is deprecated in the most recent versions of Asterisk. Give it a try - it might take a couple of minutes to get it changed over, but it is a worthy experiment.

I just did a test with one of the extensions on the ring group being PJSIP. Still no missed call.

However, I had to create a new extension. I converted the test one over to PJSIP and now it is now acting like the extension is in use.

I guess I will upgrade to Asterisk 16

Update: Switched to Asterisk 16.9.0. Still no missed call notification.

Update 2: Turned “Mark Answered Elsewhere” back on. Notifications are appearing, but earlier, end users reporting calls still reporting missed even though call was answered. Will look more into this more complaints comes up. Thanks

Today’s update. With “Mark Answered Elsewhere” set to YES. All calls are being marked as missed. A complete opposite of it being to NO.

Update: It was not me imagining the problem


@cynjut Just to let you know, it is for sure a bug in the Ring Groups module even though they claimed it was fixed https://issues.freepbx.org/browse/FREEPBX-19795 . I have the PBX on a virtual machine. I rolled back to when FreePBX 14 was on it, and downgraded the Ring Group module back to version

Thanks for taking the time to chime in.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.