v13 Having issue with Backup

So I have made a backup. actually two of them.

One of local storage and the other with legacy and local.
executed SAVE then SAVE & RUN

Looking to download I peek in the /var/spool./asterisk/backup folder I am only seeing the first backup I made when I started this install of FPBX on this server. Which I call “first_full” (folder) plus the actual .tgz file inside.

So then I did a search of the whole drive, “find / -name *tgz”


As you can see, still no backup from today’s date (17 Nov 2015) anywhere on the drive,

So Tried another approach with this “find / -name 2015*”

Only got what was in /var/spool/asterisk/backup/Default_backup

What’s going on?

I was finally able to get it to produce an error:

PHP Fatal error: Class ‘Backup’ not found in /var/lib/asterisk/bin/backup.php on line 40
Whoops\Exception\ErrorException: Class ‘Backup’ not found in file /var/lib/asterisk/bin/backup.php on line 40
Stack trace:

  1. () /var/lib/asterisk/bin/backup.php:40

Can you file a bug on this issues.freepbx.org

All Done with the bug report…


No need to report a bug. This was fixed months ago. You need to upgrade the backup module. You are running backup version 12 in 13. That doesn’t work.

If there an upgrade beyond 13.0.16 you are hiding?
Nothing newer coming up on the server,

No we are not hiding it. Please see the bug report you posted for a solution to your problem.

I did that. The problem is it should not have occurred (though bugs do happen). I did this upgrade maybe a month ago, and have played around the newer version for a while while.

Then yesterday I feel I should do a backup, and that is when I noticed this problem.
Seems AN wants to push the problem on the end user. I don’t see how it’s my fault after playing around with it and pressed the Apply Change button numerous times,.

The blame should be on whomever coded that module to make the upgrade

But enough for the ranting. Thanks for the responses.

I must say I do like version 13 better than the previous version so far.