Using RingGroup to ring cell phones - not showing caller ID?

I have a ring group setup that successfully rings extensions and dials out to cell phones (similar to Follow Me). However, when I use the Ring Group, it does not pass my outbound CID. In turn, the cell phone shows “Blocked” on the incoming calls.

Does anyone have suggestions of where to look or how to fix this? I do not want the CID of the incoming caller passed through, I just want my trunk’s CID to show in my cell phone.


The settings for each Ring Group have a setting on how to handle Caller ID. The default is to pass along the Caller ID that the call comes in with. If you’re dialing the Ring Group from an internal extension, the Caller ID you’ll pass along is your extension #, which most cellular providers would deem as invalid (and thus show blocked instead).

You can change this default in the Ring Groups settings, but that would apply to all phones in the Ring Group.

My preference is to nest your ring groups. Create a Ring Group just for your mobile phone. Adjust the Caller ID for that ring group. You might also want to enable call confirmation, so that your cellular phone’s voicemail doesn’t answer the call.

Then create another ring group to ring your internal phones AND the Ring Group for your cellular phone. Leave the CID settings at default on this one.