FreePBX | Register | Issues | Wiki | Portal | Support

Using ftp client is not possible


#21

You should probably start a new thread for this – it has nothing to do with FTP.

Although it’s possible to set up FreePBX to allow anonymous peer-to-peer connections (by setting Allow Anonymous Inbound SIP Calls and Allow SIP Guests), it’s a serious security vulnerability and is not recommended. If you really want to receive calls by SIP URI, I suggest that you sign up with a trunking provider that accepts such calls. For some, these calls are free.

Ordinary connections from remote devices, systems or services should be set up as Extensions or Trunks. Describe what you are trying to connect. If you have defined an extension or trunk for it, post the settings.

G.723 is a mostly obsolete codec that IMO sounds awful. I don’t know why Asterisk is failing to transcode it, but unless you have a special requirement, just disable it.

I don’t know why you are having DNS trouble. Assuming that name resolution works properly for system commands such as ping, it may be a formatting error in some config.


#22

It wasn’t a criticism, it was an encouragement , keep learning :slight_smile:


#23

If you use fully qualified domains for your URLconnections and not bare ip addresses they are no longer anonymous and can be be specifically filtered on by both chan_sip (add domain= your.domain) and chan_pjsip (add from_domain = your.domain )


#24

I don’t believe that it works usefully in pjsip, because it’s looking at the From header. On a SIP URI call to a ‘secret’ domain name, that name will appear in the URI and the To header, but not in the From header (without special configuration by the sender).

I believe it’s ok in chan_sip; the sip.conf entries for trunks could have e.g. provider domain names, which would override the [general] entry, though I haven’t tested that.


#25

The “special consideration” is of course assumed. Simply that all acceptable participants should be in the same domain.

Already tested by many as “working” use

/etc/asterisk/sip_general_custom.conf

Turn off your firewall and watch sngrep/the cli (when satisfied, turn your firewall on again)


(system) closed #26

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.