Using August 2022 (newest) SangomaOS .ISO (2208-2) [solved]

August 2022

We’ve built a SangomaOS box using the .ISO shown above
Asterisk 18.13.0
FreePBX 16.021.9

Inbound calls (if sent to a ring group) are not really working.
Inbound calls (if sent directly to an extension) are working fine.

There was no module update available for the ring group module.

Any tips or reply would be appreciated.

You will definitely need to elaborate and also provide call logs

[u]testing underline[/u]

More information:

1: forget call logs (if you don’t know off-hand why this happening
I’ll understand. We don’t need any SIP capturing or call logs to figure out this boggle.

This was an issue in the past: with other .ISO releases, and the fix was to upgrade the ring group module, but in this case, no upgrade exists because the .ISO is so new (I think).


2: If incoming calls are sent to a ring group:
the calling party hears NO ringing on their side.
The extension receiving the call hears ringing on their phone

3: If incoming calls are sent directly to an extension
the calling party hears ringing on their side (normal and good)
The extension receiving the call hears ringing on their phone

Without logs there can be no useful guesses, no?

Refusing to provide logs is an interesting troubleshooting choice. Have you even tried to see if RG has a module update available? Just because a module received an update doesn’t mean it’s immediately in the ISO

Not refusing to provide logs: I just know they are not needed for this fix.

Actually, its solved … (just now) I recalled what others have told me in the past about this woe:

In the ring group: you need to set

Send Progress to NO

Default is YES

Calls sent to a ring group now provide ringing to the party calling.

I don’t think anyone would have guessed that was the issue from your initial post.

It would be quicker and easier if you put more detail in your initial post that way there is less back and forth.

Also, providing the logs at the beginning can also help identify config issues from other errors.

Just out of curiousity what was the Music On Hold set to?

In the ring group: the Play Music On Hold option was set to the default of:

Ring (dropdown choice)

I still wouldn’t mind seeing the before and after call logs

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.