Users cannot input selection im a call

Hi

I recently discovered that when making calls to an ivr from my pbx that it wont take the input i select,
example for English press 1 or other,
is there a way to enable this currently none of the users can select anything when calling.

Hi.
You mean with IVR?
Maybe the issue comes from dtmf settings.
If you don’t know it, set to “auto”.

tried changing it to auto but no luck,
still cannot select anything from IVR menu.

Check different value.
Why not enable the dtmf debug in asterisk logs and check again.
You have to know what the kind of dtmf your provider is using.
There is not 100 values to set a dtmf.

  1. rfc2833
  2. inband
  3. info
  4. auto

Check the codec used with your SIP provider.
I think maybe you can read SIP traces to see what’s the dtmf is used.
Sometimes the dtmf is doesn’t work correctly with some codecs.
G711 works correctly.
G273 or G729 can’t work correctly with inband if I recall correctly

There have been a few cases recently where people have tried to accept DTMF over mobile phone air interfaces (e.g. chan_dongle). That definitely won’t work for standard GSM networks, and probably won’t work for more recent technologies.