Userman Not Syncing To Asterisk Voicemail Users

Hi Folks,

I have 2 FreePBX systems both running Both of them have no users listed under the “User Management” section. Not sure where they all went. The users can no longer log into their UCP panel, only the administrator can. Userman module is at I’ve tried upgrading userman to edge, I’ve tried rolling back to previous versions. I’ve also tried reinstalling using “fwconsole ma userman install” I don’t see any errors from userman in the logs.

In the User Manager module I have a directory setup to sync every 1 hour to “Asterisk Voicemail”, it is enabled with a context of “default”.

I tried adding a new test extension with voicemail enabled, but userman does not pick up the new extension.

Any thoughts on where I should go from here?


1 Like

Most excellent Andrew! That edge fix worked. All of the users have re-appeared. Thanks for the help.

1 Like

Hi Andrew,

I might or might not have an issue with userman version I am not able to add any of the userman users into a group to give them back their settings to allow/disallow access to UCP, phone apps, etc. The “groups” tab just says “Loading, please wait…” The dropdown menu shows the “FreePBX Internal Directory” and the Asterisk voicemail directory. When selecting the Asterisk VM directory group, there are no users listed in it and no option to change the group settings. I thought it might have been a browser issue, but I cannot change any extension’s userman group by editing their extension either.

I am seeing the exact issue. after digging a little more I checked the SQL database and it seems that in the userman_groups table, the auth field is getting filled in with the wrong information. In my case it’s being filled in with the driver name and not the ID number. Changing it to the correct number fixed the group listings on the site, but I’m still not able to add users to groups. I am currently on the edge build of userman

1 Like

it seems if you make the group and add the users before saving it works correctly, just doesn’t display in the gui.

I’m having no luck with the groups no matter what I try. Hopefully Andrew will chime in on this one. I suspect the userman module needs a programming adjustment but am not sure.