FreePBX | Register | Issues | Wiki | Portal | Support

Usereqphone=yes seems to don't work

asterisk
Tags: #<Tag:0x00007fcd2155bef0>

(Andrew) #1

A service provider requires user=phone in FROM uri like this example they send to me

INVITE sip:xxxxxxxxxx@ispsipserver;user=phone SIP/2.0
From: <sip:xxxxxxxxxx@client ispsipserver;user=phone>;tag=123456
To: sip:xxxxxxxxxx@ispsipserver;user=phone

I am using sangoma linux FreePBX 14.0.3.6 & Asterisk 15.4.0

What i tried:

  • Added usereqphone=yes in the sip trunk but user=phone is added in TO but its not added in FROM
  • In Settings > Asterisk sip Settings > Chan SIP Settings> Other sip Settings added usereqphone=yes - no changes

I am new to voip branch and wish someone can explain, maybe i am doing something wrong or this is a bug…

Debug show this:

-- Called SIP/my-trunk/0000000000

Retransmitting #1 (NAT) to ipaddress:5060:
INVITE sip:0000000000@ispsipserver;user=phone SIP/2.0
Via: SIP/2.0/UDP ipaddress:5060;branch=z9hG4bK435b22a0;rport
Max-Forwards: 70
From: <sip:+1000000000@my ispsipserver>;tag=as4439691f
To: sip:000000000@ispsipserver;user=phone
Contact: sip:0000000000@ipaddress:5060
Call-ID: 5d540c3a5131f9643cee5ab5535c883e@my ispsipserver
CSeq: 102 INVITE
User-Agent: MYPBX


(Andrew) #2

couldn’t add this because of error from forum “Sorry, new users can’t put links in posts.”
Trunk configuration:
type=friend
host=ispsipserver
fromdomain=my ispsipserver
insecure=port,invite
disallow=all
allow=alaw&ulaw
usereqphone=yes
qualify=yes
context=from-trunk
nat=yes
externip=my external ip