User Panel not accessable on Freepbx 2.11 beta

I am on the latest beta of Freepbx and have installed the User Panel from the Module Admin and have enabled the FreePBX ARI Framework but when I click on the User Panel Tab, all I get is "The requested URL /recordings was not found on this server."
Am I missing something? Is there another step I need to take?

Found my issue. It seems when I installed LAMP on my Ubuntu 12.04 it put all websites under the folder of html so that is the part that was missing from the url. Now I just need to figure out how to fix the issue.

So to get the recordings to work, I had to remove the recording folder from the html folder and place it in the /var/www folder. This made the recordings page come up. But now when I run amportal chown I get an error “chown: cannot access `/var/www/html/recordings’: No such file or directory”. Is there a way to fix this? And is this a bug? Where should everything be installed? If I also move the admin folder to /var/www everything breaks.

I have the same issue and have not been able to figure it out.

any assistance will be appreciated

You both need to reinstall freepbx. Please look at the advanced options in install_amp and you’ll see the option to define your webroot as /var/www

Note: this if for 2.11 only

it worked until i did the updates and then it broke once again, Is there a config file I can change that this is referring to?

Instead of moving files around, why not just fix your Apache config to point to /var/www/html ?

Duh, stupid me, Thanks

Here is what I did

I added to my /etc/httpd/conf.d/ssl.conf

Alias /recordings “/var/www/recordings”

Thanks miken32

To fix the issue you need to modify the https.conf file. This is located for me in the /etc/httpd/conf/http.conf aqnd you need to look for the “DocumentRoot”. Make sure that the documentroot is set to “/var/www/html”. Then everything will come up as it should.

I follow the freepbx installation guide for ubuntu 12.04, but the login to the user panel was broken.
This is how I fixed it.
my apache path for ubuntu 12.04 is:


the recordings is in /var/wwww/freepbx/recordings

to fixed it, I edit the /var/www/freepbx/admin/views/login.php and go to line number 33 and I change this line: $html .=’<a href="/recordings"‘
to $html .=’< a href="/freepbx/recordings"’

and it is working for now.