User Management - Directory

Currently, adding a directory in user management (the submit button) is broken.
Tried using FF, Chrome, IE, EDGE, Safari

Does anyone have any suggestions on how to get a directory added until the problem is fixed?
Is there a config file or a manual entry that can take place?


You currently can’t. Well. Actually I am not sure what issue you are facing as on my local machine it works.

Hopefully this works . . .

1 Like

@tm1000 just called me (he’s not in the office today) to look into this

From your gif, it appears that there’s an error off the bottom of the screen. Can you scroll down and see what is flashing?

No error at the bottom.

Hmm. It just worked for me. Maybe there’s a javascript error that you can’t see. If you push F12, you’ll get the browser debug window. There may be some errors in the bottom half there. Can you post a screenshot? It looks like this:

The other odd thing in your screenshot, is that I can see ‘FreePBX Internal Directory’ in the dropdown at the top, not Active Directory.

Here is a screen shot of my console

Screen (I will follow up with a whole process run through)

Here you can see an edit of an existing object works. However, additions seem to have an issue.

1 Like

Looks like you’ve found what I think is the problem - there is an error, but the validator is checking the openldap settings when it should only be checking the active directory settings.

This probably won’t be fixed today, unfortunately. Hopefully we can have a fix out tomorrow.

I’ll add these links to the ticket at – thanks for your assistance!

No prob. :slight_smile:

Soooooo close. Still does not submit correctly. Submits but does not commit.

Latest update works.