User Join/Leave option enabled in Freepbx conference, but it does not ask to record user name while join to conference

User Join/leave options is enabled in conference, while join to conference username is not asked to record, instead enter pin number is prompted. After pin number is entered, user is joined to conference. Followings are logs when joined to conference.
[[email protected] ~]# asterisk -r
Asterisk 1.4.24, Copyright © 1999 - 2008 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.4.24 currently running on localhost (pid = 3006)
Verbosity is at least 3
– Executing [[email protected]:1] Macro(“SIP/8000-b7701a88”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“SIP/8000-b7701a88”, “AMPUSER=8000”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/8000-b7701a88”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/8000-b7701a88”, “1|Set|REALCALLERIDNUM=8000”) in new stack
– Executing [[email protected]:4] Set(“SIP/8000-b7701a88”, “AMPUSER=8000”) in new stack
– Executing [[email protected]:5] Set(“SIP/8000-b7701a88”, “AMPUSERCIDNAME=3Cx(Soft IP 2)”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/8000-b7701a88”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/8000-b7701a88”, “AMPUSERCID=8000”) in new stack
– Executing [[email protected]:8] Set(“SIP/8000-b7701a88”, “CALLERID(all)=“3Cx(Soft IP 2)” <8000>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/8000-b7701a88”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/8000-b7701a88”, “0?continue”) in new stack
– Executing [[email protected]:11] Set(“SIP/8000-b7701a88”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/8000-b7701a88”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/8000-b7701a88”, “Using CallerID “3Cx(Soft IP 2)” <8000>”) in new stack
– Executing [[email protected]:2] Set(“SIP/8000-b7701a88”, “MEETME_ROOMNUM=1111”) in new stack
– Executing [[email protected]:3] Set(“SIP/8000-b7701a88”, “MEETME_RECORDINGFILE=/var/spool/asterisk/monitor/meetme-conf-rec-1111-1274408994.44”) in new stack
– Executing [[email protected]:4] GotoIf(“SIP/8000-b7701a88”, “0?READPIN”) in new stack
– Executing [[email protected]:5] Answer(“SIP/8000-b7701a88”, “”) in new stack
– Executing [[email protected]:6] Wait(“SIP/8000-b7701a88”, “1”) in new stack
– Executing [[email protected]:7] Set(“SIP/8000-b7701a88”, “PINCOUNT=0”) in new stack
– Executing [[email protected]:8] Read(“SIP/8000-b7701a88”, “PIN|enter-conf-pin-number||||”) in new stack
– <SIP/8000-b7701a88> Playing ‘enter-conf-pin-number’ (language ‘en’)
– User entered ‘112233’
– Executing [[email protected]:9] GotoIf(“SIP/8000-b7701a88”, “0?USER”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/8000-b7701a88”, “1?ADMIN”) in new stack
– Goto (from-internal,1111,15)
– Executing [[email protected]:15] Set(“SIP/8000-b7701a88”, “MEETME_OPTS=aAwcIMsr”) in new stack
– Executing [[email protected]:16] Goto(“SIP/8000-b7701a88”, “STARTMEETME|1”) in new stack
– Goto (from-internal,STARTMEETME,1)
– Executing [[email protected]:1] MeetMe(“SIP/8000-b7701a88”, “1111|aAwcIMsr|112233”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
– Created MeetMe conference 1023 for conference ‘1111’
– Accepting AUTHENTICATED call from 192.168.1.42:
> requested format = alaw,
> requested prefs = (),
> actual format = ulaw,
> host prefs = (ulaw|alaw|gsm),
> priority = mine
– Executing [[email protected]:1] Macro(“IAX2/5000-6771”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“IAX2/5000-6771”, “AMPUSER=5000”) in new stack
– Executing [[email protected]:2] GotoIf(“IAX2/5000-6771”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“IAX2/5000-6771”, “0|Set|REALCALLERIDNUM=5000”) in new stack
– Executing [[email protected]:4] Set(“IAX2/5000-6771”, “AMPUSER=5000”) in new stack
– Executing [[email protected]:5] Set(“IAX2/5000-6771”, “AMPUSERCIDNAME=Sales”) in new stack
– Executing [[email protected]:6] GotoIf(“IAX2/5000-6771”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“IAX2/5000-6771”, “AMPUSERCID=5000”) in new stack
– Executing [[email protected]:8] Set(“IAX2/5000-6771”, “CALLERID(all)=“Sales” <5000>”) in new stack
– Executing [[email protected]:9] ExecIf(“IAX2/5000-6771”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“IAX2/5000-6771”, “0?continue”) in new stack
– Executing [[email protected]:11] Set(“IAX2/5000-6771”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“IAX2/5000-6771”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“IAX2/5000-6771”, “Using CallerID “Sales” <5000>”) in new stack
– Executing [[email protected]:2] Set(“IAX2/5000-6771”, “MEETME_ROOMNUM=1111”) in new stack
– Executing [[email protected]:3] Set(“IAX2/5000-6771”, “MEETME_RECORDINGFILE=/var/spool/asterisk/monitor/meetme-conf-rec-1111-1274409023.45”) in new stack
– Executing [[email protected]:4] GotoIf(“IAX2/5000-6771”, “0?READPIN”) in new stack
– Executing [[email protected]:5] Answer(“IAX2/5000-6771”, “”) in new stack
– Executing [[email protected]:6] Wait(“IAX2/5000-6771”, “1”) in new stack
– Executing [[email protected]:7] Set(“IAX2/5000-6771”, “PINCOUNT=0”) in new stack
– Executing [[email protected]:8] Read(“IAX2/5000-6771”, “PIN|enter-conf-pin-number||||”) in new stack
– <IAX2/5000-6771> Playing ‘enter-conf-pin-number’ (language ‘en’)
– User entered ‘223344’
– Executing [[email protected]:9] GotoIf(“IAX2/5000-6771”, “1?USER”) in new stack
– Goto (from-internal,1111,17)
– Executing [[email protected]:17] Set(“IAX2/5000-6771”, “MEETME_OPTS=wcIMsr”) in new stack
– Executing [[email protected]:18] Goto(“IAX2/5000-6771”, “STARTMEETME|1”) in new stack
– Goto (from-internal,STARTMEETME,1)
– Executing [[email protected]:1] MeetMe(“IAX2/5000-6771”, “1111|wcIMsr|223344”) in new stack
– <IAX2/5000-6771> Playing ‘conf-onlyone’ (language ‘en’)
– <IAX2/5000-6771> Playing ‘conf-placeintoconf’ (language ‘en’)
localhost*CLI>

Could any one suggest how to enable “record your name” options during conference.

Regards
Boopathy

I have the same problem, but can’t find a fix
Freepbx 2.8
Asterisk 1.4.34

Rather than start a new topic, I thought I’d bump this one as the two problems are likely to be related.

My problem is similar - I have a conference with User Join/Leave Announcement turned ON. My users DO get asked to record their name but it is never announced to the rest of the conference when they join or leave.

Tried removing Conferences module and reinstalling, also tried upgrading from FreePBX 2.7 to 2.8 (Asterisk 1.4.21.2) but the problem persists.

Any suggestions gratefully received.

I have the same problem here with FreePBX 2.7

I have FreePBX 2.8.0.4 and also have this problem. In fact, users have been asked to record their names but have NEVER been announced when joined to the ongoing conference. Does this feature work for anyone?

I realize this is a few months old now. Was this ever resolved? I have the same problem. No request to record name. No join/leave announce.

Asterisk 1.8.4.1
FreePBX 2.9.0.7 (latest as of today)

You have to have a valid DAHDI timing device or the conference will not work correctly.

How did you install Asterisk? By rpm, by compiling it yourself or by a distro?

If you compile it by yourself then do it again with:
Go to your dahdi source directory and type:
make clean
make
make install

Then go to your Asterisk source directory and type:
make clean
make
make install

If you compile Asterisk before Dahdi is installed you don’t have a valid timing source.

You MUST compile and install DAHDI first.

Thanks to mustardman who tested this out and found out why it was not working. This is what he wrote in ticket 5158:

I had to copy libtonezone.so to /usr/lib and tonezone.h to /usr/include on the VPS to get asterisk to compile chan_dahdi.so.

This only applies when running asterisk under OpenVZ and you have dadhi running on the hardware node, in my case a Sangoma Voicetime USB stick.

It took me a little bit to figure this out. But to get the enter/leave to work “quiet mode” has to be off.