usbFXO and FREEPBX on RaspberryPI 2

Hello hard for me to make it work … so the question is what is the best configuration on raspberrypi what distribution for compatibility on sangoma usbfxo to get my two analog lines working on the system ?

Any clear help would be mostly appreciated thank you and sorry for my lack of knowledge … i am new user …


Buy a SIP gateway like the OBI, USBFXO are deprecated and if you dont want to mess recompiling kernels and modules for yur RPi then thats the alternative.

thanks for your answer … no-one has experience with sangoma usbfxo on raspberrypi ?

whats the difference between OBI and SANGOMA cause they say its a gateway too …

My understanding is that a “gateway” device (regardless of manufacturer) is designed to connect a specific type of connection to a SIP device and act as a trunk. Back in the olden days, we used to have routers and gateways for connecting local networks to other networks. If your local network was the same type (IP, Token Ring, etc.) as the network you were connecting, you would use a router. If not, you would use a gateway. The differentiation was the protocol conversion.

So, a phone is not a gateway device because it connects directly to the PBX. Similarly, an ATA (analog telephone adapter) isn’t usually considered a gateway because it doesn’t connect as a trunk (it doesn’t interconnect two networks).

On the other hand, a device that connects to a couple of incoming phone lines and presents them to the PBX as a SIP trunk would be, since it is providing a connection outside the network and looks like a trunk to the server.

I do, no funny thing you need to recompile the kernel if you are using a popular distro to have the headers, you need to compile Dahdi to support the usbfxo stuff with the sangoma. So far there is a missing structure which cause a failure during the creatiing of the module.



Sangoma is a USB gateway, OBi is a SIP gateway.

1 Like

Ok great now it’s very clear to me usbfxo is not the good choice … ok … do you have experience with the OBI100 or OBI 110 on raspberrypi supposed to be gateways and accepting one FXO …

If you use USB/FXO/FXS, you have to consider the power supply from PI, which might be not sufficient for power supply. Gateway is an external device, it is nothing related with server, as long as you can connected with a trunk between Pi and OBI100 or Sangoma Vega.

I’ve been using an OBi110 as an FXO port to FreePBX on a Raspberry Pi for over two years now and it works very well. The following is the configuration I use:

OBi110 (All settings at Default unless specified below):

Service Providers -> ITSP Profile B -> General -> Name : FreePBX[OBi110LINE]
Service Providers -> ITSP Profile B -> SIP -> ProxyServer : (FreePBX Server IP Address)
Service Providers -> ITSP Profile B -> SIP -> X_SpoofCallerID : (Checked)
Service Providers -> ITSP Profile B -> SIP -> X_AccessList : (FreePBX Server IP Address)

Voice Services -> SP2 Service -> X_ServProvProfile : B
Voice Services -> SP2 Service -> X_InboundCallRoute : {li}
Voice Services -> SP2 Service -> AuthUserName : obi110line
Voice Services -> SP2 Service -> AuthPassword : (Trunk Password)
Voice Services -> SP2 Service -> MaxSessions : 10

Physical Interfaces -> LINE Port -> InboundCallRoute : {sp2(2345678901)} (2345678901 = PSTN Number)

FreePBX Trunk:

Trunk Name : OBi110LINE

Outgoing Settings:

Trunk Name : obi110line

PEER Details:

secret=(Trunk Password)

FreePBX Outbound Route:

Route Name : OBi110LINE

Dial Patterns that will use this Route : (As Appropriate)

Trunk Sequence for Matched Routes : OBi110LINE

FreePBX Inbound Route:

Description : OBi110LINE

DID Number : 2345678901 (2345678901 = PSTN Number)

Set Destination : (As Appropriate)

I am testing FreePBX with the same config, Pi and OBi110.

Asterisk 13.26.0

For the setup I have tried:
and reraikes config above.

The terminal shows WARNING[17060]: res_pjsip_registrar.c:1089 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs

What am I missing?

For the ITSP Profile in question:
SIP -> ProxyServerPort : 5160
SIP -> RegistrarServerPort : 5160

If you still have trouble, post log of failing call.

You should probably open a new thread for this. Your present issue has nothing to do with either usbFXO or RPi.

The OBi FXO is now registering with the 5160 port change.