Uploading Sound recording Error

Hello, I started using freePBX (via PBX-in-a-Flash) today as part of the VoIP OS testing and evaluation phase of moving to IP Telephony and am enjoying using it a lot.

I do have one problem though, when I try to upload a sound recording I get an error :

[ERROR] The Recorded File Does Not exists:

make sure you uploaded or recorded a file with the entered extension

I have seen a few instances of this elsewhere but the resolutions were different and don’t seem to apply. I am running this virtualised, but this is the least likely thing I expected to break as it would expect the uploading computer to be remote anyway.

Any help with this would be greatly appreciated. I have tried MP3s, WAVs and strictly encoded WAVs (matching the states 16bit, 8000 spec.)

Haven’t yet tried recording from a mic, but need to use the files anyway, so it wouldn’t solve the problem,

Thanks in advance,


It works correctly when recording from line-in/mic, so it’s specifically the WAV/MP3 uploading. I also tried using a lower sample rate WAV and it still doesn’t do anything. Doesn’t even seem to wait long enough for the file to theoretically transfer.

Any ideas?