Upload module


I am trying to upload a call statistic module and each time i do i’m getting an error:

Error finding uploaded file - check your PHP and/or web server configuration

Has anybody got any idea how i can solve this please?

Thank you!

More details please. What version of FreePBX, what module are you trying to upload, how are you uploading it. We need enough info to reproduce what you are seeing.

Thank you for the reply.

I am trying to upload the module found here:

I am using the Module Admin Tab in FreePBx - then upload Module.


I can confirm that that module works with your version of FreePBX (and others). It is possible that the problem you are seeing is a symptom of a bigger problem, tho I don’t know what. You can try uploading the file using a different browser and you can check the httpd log file for a clue. If you are still stumped, post back with how you installed the system (i.e. manual install or by distro and which one), hopefully someone else can help.

Thanks again,

I’ve tried explorer, chrome and firefox to no avail :frowning:

IT was installed by downloading the ISO from freepbx’s site.

I’ve been days trying to get it to work so i am stumped to be honest

Has no-one seen this error before?

Maybe there is another way to somehow graph the concurrent calls on FreePBX?

I managed to solve this by changing:

The PHP config file at: /etc/php5/apache2/php.ini
The line you’re looking for is: upload_max_filesize

from 2MB to 4MB.

Then just restart apache.

Now i have the module but unfortunately its not displaying graphs. I can see like a broken small square icon where its ‘trying’ to display the graph.

any ideas why? I’ve tried multiple browsers.

Regarding the issue with upload_max_filesize, I actually knew about that once upon a time. I added to the wiki so I won’t forget again.

As to the graph display issue, it looks like the jpgraph library is not loading. I don’t know what might cause that. Can you confirm that the folder:
exists and contains the files listed here

Every time i try to generate a graph i see this error in the apache log:

[Wed Dec 12 09:44:54 2012] [error] [client] PHP Notice: Use of undefined constant IMG_PNG - assumed ‘IMG_PNG’ in /var/www/html/admin/modules/callstatistics/jpgraph_lib/jpgraph_errhandler.inc.php on line 282, referer:

does that help? :slight_smile:

Apologies, it is there:

-rw-r–r-- 1 asterisk asterisk 204582 2012-03-22 17:50 jpgraph.php

It just wasn’t in the same order as the list so i missed it.

So - all the php files are there.

any ideas please?


Thanks for your reply.

That directory has all of the files listed EXCEPT jpgraph.php. Is that my problem?

Shall i copy that php file and place it in this directory?

Kind Regards


That is a clue. This module relies on the jpgraph library which in turn requires the ‘gd’ extensions for PHP. To check if PHP is compiled with ‘gd’ extensions, at the CLI issue the command:
php -m
and check the list of PHP Modules for ‘gd’

There is no GD in the list…which means i have to install it right? Any idea how and what it will effect?

Well I guess that pretty well solves the mystery.

The question re: gd needs to be answered by Schmooze. Suggest you post in the distro forum with the actual specific version of your system with a request for installation steps and whether it is recommended or not.