Upgrate 13 : file_get_contents(/etc/schmooze/operator-panel-brand): failed to open stream

So, just upgraded to FreeBPX 13 - everything except the Web Interface is running perfectly (even after a total reboot).

When I log into my web server I get the following :
file_get_contents(/etc/schmooze/operator-panel-brand): failed to open stream: No such file or directory

/var/www/html/admin/modules/cxpanel/brand.php

<?php $cxpanelBrandName = file_get_contents('/etc/schmooze/operator-panel-brand');if($cxpanelBrandName === FALSE || trim($cxpanelBrandName) == "") { $cxpanelBrandName = 'iSymphony';} $cxpanelBrandName = trim($cxpanelBrandName); One word==> HELP! (please).

Engaged brain!

went to ‘/etc/schmooze’ and noticed that the file there was called “PBX-Brand” and not “operator-panel-brand”

so ran the following cp pbx-brand /etc/schmooze/operator-panel-brandand now it’s working

1 Like

Alternatively just upgrade all modules.

1 Like

I ran in to the same issue.

Our main system uses a i386 kernel.

Made a new system using 64 .

Restored a full backup.

and had the same error messages on web page.

I tried this 1ST:
fwconsole moduleadmin upgradeall

same issue, this fixed it:
cd /etc/schmooze
cp pbx-brand operator-panel-brand

Note on the 386 system ‘pbx-brand’ is used and it runs fine.