Upgrading from FreePBX 13 to FreePBX 15


I’m trying to migrate from FreePBX 13 (FreePBX to FreePBX 15 (FreePBX

I did a full backup on FreePBX 13 using the “Backup & Restore” module, via the GUI.

Then I went to retrieve the backup file In /var/spool/asterisk/backup

In FreePBX 15 I tried to restore in via the GUI (upload the file) but it would always hang at 99,99% for hours.

So I did it through the CLI using this command:
fwconsole backup --restore FILE

It took a while but it completed successfully.

Just for good measure, I did ran
fwconsole chown
fwconsole r

Now FreePBX is completely messed up.

  1. It reports : can’t connect to Asterisk

  2. There’s a LOT of items that are in “Italic” in the menu (which I’ve never seen before) and so I assume they’re disabled.

Is there any way I can repair it or should I try something else for upgrading?

The error with connecting to Asterisk probably means either Asterisk is not running (do fwconsole restart) or the manager password is incorrect. The menu items are disabled because Asterisk is disconnected.

If Asterisk is running this it’s probably an issue with manager credentials. If Advanced settings is accessible in the gui, make sure the manager credentials match what’s in /etc/asterisk/manager.conf. If not, CLI commands are available to resolve:


When running

fwconsole restart

It just keeps whining about Asterisk not running

I can’t access Advanced settings in the GUI, it just gives me a page with a blank box (where the fields should be).

So I tried running the commands in the linked post and here’s the result.

[[email protected] ~]# fwconsole setting AMPMGRUSER admin
Changing "AMPMGRUSER" from [XXX] to [admin]
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

I’ve tried looking it up and I’m not sure what it means.

It’s a clean install from the DISTRO.

The only things I did is:

  • Upgrade modules
  • Restore backup

Did I break anything?

Should I start from scratch again or is there a way to fix this?

Sorry for being such a n00b but I’m at lost here

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.