Upgraded to freepbx-2.3.1

I just attempted to upgrade using the freepbx-2.3.1.tar.gz file. However, after the upgrade and I log in to the module admin page it shows the following modules are broken:
sysstatus, configedit, irc, logfiles, backup, sysinfo, javassh, ivr, conferences, asteriskinfo, timeconditions, and ringgroups. How do I go about fixing the broken modules so that i can download the upgrade before clicking on the red bar that says to apply changes?

Thank you,

what were you running previously? And what options did you use when running install_amp?

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

This was setup by someone else previously, so I’m not sure what version they were running before. When I first ran install_amp, it gave me an error about unable to re-declare some function. I then searched the forums and came across suggestions to use the --force switch. I tried some of the earlier versions. and got it to upgrade without the error about re-defining a function.

I figured out how to uninstall the modules that are broken and am re-installing them now. However, I am now getting a new error message on the admin homepage under FreePBX Notices. It is
SELECT * FROM incoming WHERE cidnum = “” AND extension = “” AND channel = “” [nativecode=1054 ** Unknown column ‘channel’ in ‘where clause’]

Thank you for your quick response to my original post.

you are going to have to reinstall from the tarball with the --force-version option again. You need to set a version the reflected what you were previously running or prior to what you were previously running. If you are not sure, try 2.0.0 and it will probably get everything updated correctly.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx


I got the same posted error. I upgraded from ver 2.2.3. I used the {–force} command but I still get the same error whenever I go to Inbound route-- and trying to modify an incoming route.

I hope you can help me…I’m new with FreePBX.

Thanks in advance.