Upgraded to freepbx 13 now having issues

I just upgraded to FreePBX 13 and it restarted in middle now, it failes when I attempt to apply config
`exit: 1
Whoops\Exception\ErrorException: Invalid argument supplied for foreach() in file /var/www/html/admin/modules/core/functions.inc.php on line 4251
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/core/functions.inc.php:4251
  2. Whoops\Run->handleError() /var/www/html/admin/modules/core/functions.inc.php:4251
  3. core_devices_get_user_mappings() /var/www/html/admin/modules/core/functions.inc.php:43
  4. core_conf->map_dev_user() /var/www/html/admin/modules/core/functions.inc.php:477
  5. core_conf->generate_sip_additional() /var/www/html/admin/modules/core/functions.inc.php:104
  6. core_conf->generateConf() /var/www/html/admin/libraries/BMO/FileHooks.class.php:65
  7. FreePBX\FileHooks->processOldHooks() /var/www/html/admin/libraries/BMO/FileHooks.class.php:24
  8. FreePBX\FileHooks->processFileHooks() /var/lib/asterisk/bin/retrieve_conf:892`

Try to execute these to see what is happening

fwconsole chown
fwconsole stop
fwconsole start

Just tried, didnt help.

Thank you

If you can, just keep going. You don’t have to apply the changes until you are completely though.

I made a lot of changes, but apply still gives me the same error