Upgraded pbdirectory and now hangups when dialing 411

When I watch it using asterisk -vvvvvcr it shows me dialing 411 then

– Executing [[email protected]:4] AGI(“SIP/307-00000207”, “pbdirectory”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/pbdirectory
– <SIP/307-00000207>AGI Script pbdirectory completed, returning 0
– Executing [[email protected]:5] GotoIf(“SIP/307-00000207”, “1?hangup,1”) in new stack
– Goto (from-internal,hangup,1)
– Executing [[email protected]:1] Hangup(“SIP/307-00000207”, “”) in new stack

Not sure what to try, have enabled Debug in pbdirectory and it creates a log file but doesn’t write anything to it.

Try logging into the console as ‘root’ and running the command from the prompt. It might be erroring in a way that the system doesn’t recognize.

Sorry if this is dumb, how do I run that command? I’m logged into the console as root, I entered /var/lib/asterisk/agi-bin/pbdirectory and it says no such command. I’ve verified the file exists in the path.

To be clear, I SSH into the PBX as root, then I enter asterisk -r, which brings me to the CLI and then I tried both php /var/lib/asterisk/agi-bin/pbdirectory and php php /var/lib/asterisk/agi-bin/pbdirectory with same error.

I didn’t tell you to connect to Asterisk. Just enter the command at the command line (instead of connecting to Asterisk).

I did that and it just hangs until I hit Ctrl+C

I downloaded v2.11.0.5 from GitHub and unzipped it to /var/www/html/admin/modules/pbdirectory and then copied pbdirectory file from /var/www/html/admin/modules/pbdirectory/agi-bin over to /var/lib/asterisk/agi-bin/

It’s now working again. Is there anything else I need to do? I noticed in Module Admin it doesn’t show it as installed anymore but that’s not a huge deal.

Try installing the file locally using module admin.

I did but it doesn’t like the format of the zip file I guess from Github. I renamed it to pbdirectory-2.11.0.5.tar.gz but maybe needs a certain folder structure in there that it doesn’t have

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.