Upgraded my PBX and my door phone quit working


(Jeffrey Angus) #1

About three years ago, after help from here, I got my Bogen ADP-1 analog door phone working.
I’ve upgraded my system to: Asterisk 16.15.0 and FreePBX 15.0.16.81.
My door phone stopped working.
Pressing the call button does nothing.
If I call the door phone (Ext 1001) it answers, It can transmit, but doesn’t receive.

/etc/extensions_custom.cof is set up:
[Bogen-ADP1-01] ; house
exten => s,1,Dial(LOCAL/5300@from-internal) ; ring group 5300
exten => s,n,Hangup()

It’s connected to an FXS port, channel 7.
Instant answer, context Bogen-ADP1-01

Now before someone suggests looking at the wiki, it’s a blank page dated 2015.
Wiki Door Phones


#2

I would suggest looking at the logs first. /var/log/asterisk/full


(Jeffrey Angus) #3

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [s@Bogen-ADP1-01:1] Answer(“DAHDI/7-1”, “”) in new stack

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [s@Bogen-ADP1-01:2] Goto(“DAHDI/7-1”, “from-internal,5300,1”) in new stack

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx_builtins.c: Goto (from-internal,5300,1)

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:1] ResetCDR(“DAHDI/7-1”, “”) in new stack

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:2] NoCDR(“DAHDI/7-1”, “”) in new stack

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:3] Progress(“DAHDI/7-1”, “”) in new stack

[2020-12-19 21:02:12] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:4] Wait(“DAHDI/7-1”, “1”) in new stack

[2020-12-19 21:02:13] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:5] Playback(“DAHDI/7-1”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack

[2020-12-19 21:02:13] VERBOSE[6608][C-00000749] file.c: <DAHDI/7-1> Playing ‘silence/1.ulaw’ (language ‘en’)

[2020-12-19 21:02:14] VERBOSE[6608][C-00000749] file.c: <DAHDI/7-1> Playing ‘cannot-complete-as-dialed.ulaw’ (language ‘en’)

[2020-12-19 21:02:17] VERBOSE[6608][C-00000749] file.c: <DAHDI/7-1> Playing ‘check-number-dial-again.ulaw’ (language ‘en’)

[2020-12-19 21:02:19] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:6] Wait(“DAHDI/7-1”, “1”) in new stack

[2020-12-19 21:02:20] VERBOSE[6608][C-00000749] pbx.c: Executing [5300@from-internal:7] Congestion(“DAHDI/7-1”, “20”) in new stack

[root@freepbx asterisk]#


#4

That’s strange, it looks like it’s the Ring Group that’s not working.

Please confirm that when you dial 5300 from a regular extension it works properly.


(Jeffrey Angus) #5

Over on another forum, they have an emoji of hitting yourself in the head with a hammer.
Insert that emoji here. Sigh.
Checking my ring groups, 5001, 5002, 5003, 5004.
Oh, look at that, NO 5300 or 5400.
Change the extensions_custom.conf to reflect the correct ring group and it works now.

I have four door phones, the original I bought 4 years ago, one I bought last year and a pair I just recently acquired “as is”.
The original one decided it no longer transmits. (Failure)
The second one works perfectly.
The two “as is” have issues.
Normal pricing on eBay is $175-225, I bought the pair of “as is” for $55, it was a gamble.
Looks like I get to trouble shoot and repair three of them.

Thank you to Billsimon and Stewart1 for the help with this.

Jeff


(Itzik) #6

Just a general note, I’d rather use a Goto than a Dial

exten => s,n,Goto(from-internal,5300,1)

That way you can fully make use of the settings in the GUI


(Jeffrey Angus) #7

This is currently what I’m using:

[Bogen-ADP1-01] ;house
immediate=yes
exten => s,1,Answer()
exten => s,n,Goto(from-internal,5003,1) ; 5003 is the ring group for the house
exten => s,n,Hangup()
[Bogen-ADP1-02] ;shop
immediate=yes
exten => s,1,Answer()
exten => s,n,Goto(from-internal,5004,1) ; 5004 is the ring group for the shop
exten => s,n,Hangup()


(Jeffrey Angus) #8

One last thing, the second door phone is via a SIP ATA adapter.
PJSIP doesn’t have an obvious “Immediate” Yes/no like the DAHDI extension has.
Where do I set that to “immediate” like I can with the DAHDI extension?


#9

It couldn’t possibly – the ATA doesn’t even contact Asterisk until it has a complete number to dial.
You need to set up the ATA to dial 5004 as a ‘hotline’.
Cisco/Linksys/Sipura: see https://community.cisco.com/t5/atas-gateways-and-accessories/spa122-configuration-to-setup-a-hotline/td-p/3787513 .
Grandstream: see admin guide for Auto Dial


(Jeffrey Angus) #10

Thank you.
Advanced settings. Line 1:
([2-9]11S0|[2-9]xxxxxxS0|[2-9]xx[2-9]xxxxxxS0|*67S0|[*x][*x].S4)
I guess this is what I have to change then.
(P0 <:5004>)


(Jeffrey Angus) #11

So of course, I do that, I get a dial tone and nothing else happens.

This was directly from the Cisco SPA100 Series Phone Adapters
SPA112 and SPA122 manual.

• Create a hotline on a line button for an extension
(P0 <:1000>)
With the timer set to 0 seconds, the call is transmitted automatically to the
specified extension when the phone goes off hook.


(Jeffrey Angus) #12

Any ideas here?