Upgraded modules for warmspare, cannot access via GUI now - no Ip or firewall changes

Upgraded oem branding and system admin module to the latest version via GUI on our warm spare.

Cannot access via GUI now but can SSH fine. Tried fwconsole stop start with no success.

What is the process to try and get the GUI back on. No firewall or IP changes were made just a simple module update as mentioned above.

service httpd restart?

I just tried now.

Redirecting to /bin/systemctl restart httpd.service

Same results

from web browser:

This site can’t be reached

**** refused to connect.

Maybe try service iptables stop

and then try to access. Or try from a different browser

Didnt work. When I login via SSH it doesnt show the typical update info instead I get this:

| No System update information available, please try later |

Is there a way to reload all the modules?

Perhaps you got banned by fail2ban?

service fail2ban stop

What does this mean exactly?

It’s the set of features that allow you to make the system look like “your” system instead of Sangoma’s system.

I know what “OEM Branding” is and my question wasn’t “What is OEM Branding” my question was “What does this mean?” in reference to the “Upgraded OEM Branding”. In other words, “how was this update done/achieved?” because “Upgraded OEM Branding” doesn’t really mean jack.

Does that mean the OP has an official OEM Branded ISO of FreePBX? Because if that is what is actually happening, we could be completely flying blind as those ISO’s are built to the specs of the OEM holder and not only do they have their own ISO for installs/releases, they have their own upgrade/maintenance path in reference to that OEM ISO.

So if this is truly an OEM release and the OP made system updates (yum, etc) to the system and then things broke, they need to follow the right support path for their OEM release. They have one, it’s part of the program.

Now if this whole “OEM Brand” is not a real Sangoma OEM ISO but some third party (IncrediblePBX, etc) or a manual install then that should be clarified as well.

1 Like

I ran updates in the module update page and there was an update for OEM Branding and System admin, so I can those 2 updates via GUI. We do not use the feature but always keep everything updated as much as possible.

So now this is where we need some real clarification. When you are referring to “OEM Branding” what are you referring to exactly? There is no module called “OEM Branding” in the FreePBX 13 or FreePBX 14 distros. So if there is a module called “OEM Branding” in your Module Admin for updates then you either A) do not have the official ISO installed or B) You have an official OEM ISO and general support for it really can’t be found here.

There is a module in FreePBX 13 called “PBX Upgrader” which would take your modules/GUI to FreePBX 14 but it would require the entire system be updated as well.

So please clarify what you mean by “OEM Branding”, screenshot from Module Admin would be even more helpful. Because this may not be something you can get help with here.

B. We have PBxact but prefer to come here and learn when things go wrong instead of just having support fix it all.

Screenshot attached. Will contact support since there doesnt seem to be a solution here. Thanks for the the advice on what to try thus far.

There is a module with rawname oembranding on PBXact (and other) systems.

@dannyprecise the output from:

fwconsole sa ports

will include a line like:

| 2001       | acp         |

telling you what Apache port the Admin Control Panel is running on. You will use that port to browse to the acp, i.e.:


If the above doesn’t work, it looks like you’re on a PBXact system, open a support ticket to get it sorted. https://support.sangoma.com

Yeah, figured it was a commercial based distro they had.

Ran it and it shows port 2001.

Running on port 2001 and now I can get in via GUI. It was running on port 80. How would that get changed from 80 to 2001?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.