Upgraded freepbx (yum update) now wanrouter kernel errors... help

Last week, I installed the latest freepbx. After I configured it and ran it for a while, I decided do an update. Now wanrouter/wanpipe will not detect my sangoma card. What is the best way to fix this? I have attempted to reinstall the kernel module from yum to no avail…

/etc/init.d/wanrouter start

Starting WAN Router…
Loading WAN drivers: wanpipe FATAL: Error inserting wanpipe (/lib/modules/2.6.32-358.14.1.el6.x86_64/kernel/drivers/net/wan/wanpipe.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Failed to load wanpipe modules !

WANPIPE™ Hardware Support Module 7.0.4.0 © 1994-2013 Sangoma Technologies Inc
usbcore: registered new interface driver sdlausb
WANPIPE™ Interface Support Module 7.0.4.0 © 1994-2013 Sangoma Technologies Inc
wanpipe: no symbol version for dahdi_hdlc_putbuf
wanpipe: Unknown symbol dahdi_hdlc_putbuf
wanpipe: no symbol version for _dahdi_ec_span
wanpipe: Unknown symbol _dahdi_ec_span
wanpipe: no symbol version for dahdi_alarm_notify
wanpipe: Unknown symbol dahdi_alarm_notify
wanpipe: no symbol version for dahdi_hdlc_getbuf



wanpipe: no symbol version for _dahdi_transmit
wanpipe: Unknown symbol _dahdi_transmit

wanpipe-7.0.4-kernel.2.6.32.358.14.1.el6.dahdi.2.7.0.rel.48.x86_64

[[email protected]]# uname -a
Linux add19 2.6.32-358.14.1.el6.x86_64 #1 SMP Tue Jul 16 23:51:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Depending on how you installed your FreePBX system using yum to update can cause problems. Did you install a FreePBX Distro or did you install FreePBX GUI on an existing Asterisk install? What versions?

I installed the freepbx distro…

in /usr/src there is a freepbx-2.11.10

dahdi_cfg -vvv
DAHDI Tools Version - 2.7.0

Thanks for the help.

cat /etc/schmooze/pbx-version
4.211.64-6

We’re seeing the same issue on a new installation.

cat /etc/schmooze/pbx-version

4.211.64-5

uname -a

Linux new-hampshire 2.6.32-358.14.1.el6.x86_64 #1 SMP Tue Jul 16 23:51:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

While attempting to go to freepbx 4.211.64-6 via the upgrade-4.211.64-6.sh script on a new, fresh install. The wanpipe drivers do not seem to get imported in the kernel…

The upgrade script attempts to update the kernel… I turned off kernel updates in yum.conf to make sure it wasn’t me causing the issues… when I did that I ran the upgrade-4.211.64-6.sh and the error-ed output was:

–> Finished Dependency Resolution
Error: Package: kmod-dahdi-linux-2.7.0-45_centos6.2.6.32_358.14.1.el6.x86_64.x86_64 (pbx)
Requires: kernel-x86_64 = 2.6.32-358.14.1.el6
Installed: kernel-2.6.32-358.0.1.el6.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
kernel-x86_64 = 2.6.32-358.0.1.el6
Error: Package: wanpipe-7.0.4-kernel.2.6.32.358.14.1.el6.dahdi.2.7.0.rel.48.x86_64 (pbx)
Requires: kernel-x86_64 = 2.6.32-358.14.1.el6
Installed: kernel-2.6.32-358.0.1.el6.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
kernel-x86_64 = 2.6.32-358.0.1.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Basically, if I update the kernel to 2.6.32-358.14, wanrouter/wanpipe/dhadi all blows up…

I am unsure of the best way to fix it aside from format/reinstall with no updates (trying not to have to reconfigure everything again)… suggestions are welcome.