Upgrade to FOP2 - how?

I have the Tango distro which was installed about a year ago. I’ve upgraded the FreePBX UI through the 2.10 releases, currently on 2.10.0.4.

Problem is, FOP is no longer supported, but my system hasn’t upgraded to FOP2, so I guess I need to do this manually. I’ve had a couple of attempts but basically ended up in a mess, it just isn’t clear to me how to proceed. I’ve managed to roll back my changes to a point where the original FOP is still operational, but it is a bit broken. So I’m between a rock and a hard place.

What is the recommended/correct way to upgrade the Tango distro to FOP2, please?

What is a Tango Distro? I can’t even find a Google reference?

FOP is no longer distributed with FreePBX as of FreePBX 2.10. However when FOP was removed from our supported modules, we did add it to our unsupported repo. If you go to Module Admin, and click on the Unsupported repo and then Check Online you should see the old FOP in your list of modules to install. Please keep in mind that your mileage may vary using FOP.

As for installing FOP2. If you are on the Official FreePBX Distro (which was downloaded from http://www.freepbx.org/freepbx-distro), you would do the following:

yum install fop2-freepbx

Please note that you can also see a list of our add-on rpms at http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/add-on-rpms

Just tried this and it broke my system.
Red Apply button came up and could not reload. got retrieve_conf error.
Found to be FOP2 buttons missing or something.
Ended up renaming fop2admin directory to kill it from /var/www/html/admin/modules to fix.

This resolved my problem.

I guess that would be the FreePBX distro - their home page refers to it as “Tango & Schmooze”.

When you say “resolved” - did you end up with a working FOP2?
–Tim

Just dont do it …
Installed fresh distro and run update scripts as per distribution doco.
Then installed fop2-freepbx and it broke freepbx
Same thing cant save any changes.
Have setup a test server on vmware so I can snapshot and test.
Isymphony looks cool but for a small number of users fop2 looks better and pricing is more appealing so will try and get fop2 going.

The fop2 RPM comes straight from the fop2 developer, all we do is drop them in our repos. I do know that we have had people reach out to let them know the rpm is broke, so we are just waiting on the new rpm from them.

Thanks everyone. So I think what we’re saying here is that it’s broken. I knew this already because I tried to upgrade and ended up with a hosed system. I managed to back it out to the point where my original FOP still works, sort of, but it is crippled and doesn’t update when I remove extensions.

So this is actually a very serious issue, especially since the old FOP is no longer supported. Does it need to be reported as a bug or something? How would I go about that, please?

–Tim

fyi - using the latest distro as of today 1.811.2.10 did yum install fop2-freepbx, and it would just stall at the “login attempt 1” screen.

i downloaded the latest source from fop site, and it worked flawlessly, they also have an updated admin module for freepbx 2.10:

cd /usr/src
wget http://download2.fop2.com/fop2-2.26-centos5-i386.tgz
tar xzf fop2-2.26-centos5-i386.tgz
cd fop2* 
make install
service fop2 restart

I test freepbx all the time in VM, and it seems fop2 works perfect 99.9% of the time when installed from source - this whole “unsupported” approach just seems like laziness and/or bias towards another vendor that is paying for inclusion - rather than “unsupported”, maybe we should say “un-preferred” - as the fop2 developer definitely seems to put some effort towards supporting FreePBX (credit due?).

Interesting. Did that integrate correctly with the FreePBX home page? That is, when you click the Operator Panel button, does that go to FOP2?

Hey Nameofthedragon,
Just letting you know if you go into advanced settings and set:
Display Hidden Settings
Display Readonly Settings and
Override Readonly settings

to True and apply, then go down until you see
FOP Web Root Dir

remove isymphony and type fop2
press green tick then apply …

All done :slight_smile:
Now the Operator Panel link from the initial web interface works :slight_smile:

Thank you so much totalimpact … your advise helped me alot and i was finally able to get FOP2 working on my system.

[[email protected] ~]# cat /etc/schmooze/pbx-version
5.211.65-10
[[email protected] ~]# yum install fop2-freepbx
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

  • Webmin: download.webmin.com
    Setting up Install Process
    No package fop2-freepbx available.
    Error: Nothing to do
    [[email protected] ~]# yum list all | grep fop
    fop.i686 0.95-4.2.el6 base
    fop-javadoc.i686 0.95-4.2.el6 base

Certainly Nicolas (FOP2 developer) has put time into integrating with FreePBX. He also has the right to market his product through his own channel. It’s not a question of “paid inclusion”

With everything that Schmooze has to take care of don’t you think you would rather have them working on their modules then testing someone else’s RPM?

It is also very simple to download and install as you pointed out.

To hint at commercial bias or any conflict with Nicolas is reckless and inaccurate.