Upgrade to 4.211.64-6 wanpipe fails Kernel module not found

Background…

I completed a configuration and setup of the latest freepbx distro 4.211.64-5 and updated it with the update script:

cat /etc/schmooze/pbx-version
4.211.64-6

That script updates the kernel to 2.6.32-358.0.1.el6.x86_64

Now wanpipe/wanrouter is broken due to some kernel modules not being right…

/etc/init.d/wanrouter start

Starting WAN Router…
Loading WAN drivers: wanpipe FATAL: Error inserting wanpipe (/lib/modules/2.6.32-358.14.1.el6.x86_64/kernel/drivers/net/wan/wanpipe.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Failed to load wanpipe modules !

dmesg:

WANPIPE™ Hardware Support Module 7.0.4.0 © 1994-2013 Sangoma Technologies Inc
usbcore: registered new interface driver sdlausb
WANPIPE™ Interface Support Module 7.0.4.0 © 1994-2013 Sangoma Technologies Inc
wanpipe: no symbol version for dahdi_hdlc_putbuf
wanpipe: Unknown symbol dahdi_hdlc_putbuf
wanpipe: no symbol version for _dahdi_ec_span
wanpipe: Unknown symbol _dahdi_ec_span
wanpipe: no symbol version for dahdi_alarm_notify
wanpipe: Unknown symbol dahdi_alarm_notify
wanpipe: no symbol version for dahdi_hdlc_getbuf
wanpipe: Unknown symbol dahdi_hdlc_getbuf
wanpipe: no symbol version for __dahdi_mulaw
wanpipe: Unknown symbol __dahdi_mulaw

Any update time frame for this to be fixed…?

There is a ticket open on it. http://issues.freepbx.org/browse/FPBXDISTRO-9

Run the following command, that will update the wanpipe rpm to a version that works.
rpm -Uvh http://packages.schmoozecom.net/pbx-shared/el6/x86_64/RPMS/sangoma/wanpipe/2.7.0/wanpipe-7.0.4-kernel.2.6.32.358.14.1.el6.dahdi.2.7.0.rel.49.x86_64.rpm

The RPM has been fixed in the repos. You can yum update wanpipe to get the fixed version.