Upgrade to 2.210.62


I just wanted to share that I successfully upgrade one of my FreePBX distros from 1.818.210.58-1 to 2.210.62 with no problems so far. I backup up the settings from the old FreePBX distro and restored them to the new one. I choose NOT to restore /etc/freepbx.conf and /etc/asterisk/cdr_mysql.conf so that the newly generated mysql password will work.

A question: Can I upgrade asterisk 1.8 to 10 on 2.210.62? I only used asterisk 1.8 so there wont be any problems from the backup-restore procedure.

Thank you,

Yes you can use the new asterisk-version-switch script to change between Asterisk versions on the fly on the 2.210.62 and 3.211.63 Distros.

Thank you tony,

I did it and it works ok so far. I only got an error message:

Please wait…

chmod: cannot operate on dangling symlink /var/lib/asterisk/bin/ampbackup.php' chmod: cannot operate on dangling symlink/var/lib/asterisk/bin/dumpastdb.php’
chmod: cannot operate on dangling symlink /var/lib/asterisk/bin/fax-process.pl' chmod: cannot operate on dangling symlink/var/lib/asterisk/bin/restoreastdb.php’
Permissions OK[/code]

That is the product of ‘amportal chown’.

How can I fix this?

Thank you,

Undangle your simlink :slight_smile:

I don’t know where the other one goes but the format of the command is ln -s sourece_file destination_file

And where should I point them? Or ‘amportal chown’ will do the work for me ?

At the moment those 4 symlinks are:

ampbackup.php -> /var/www/html/admin/modules/backup/bin/ampbackup.php
dumpastdb.php -> /var/www/html/admin/modules/backup/bin/dumpastdb.php
fax-process.pl -> /var/www/html/admin/modules/fax/bin/fax-process.pl
restoreastdb.php -> /var/www/html/admin/modules/backup/bin/restoreastdb.php

As you can see

ls -lah /var/www/html/admin/modules/backup/bin/
total 28K
drwxr-xr-x 2 asterisk asterisk 4.0K Oct 16 16:54 .
drwxr-xr-x 7 asterisk asterisk 4.0K Sep 25 12:19 ..
-rwxr-xr-x 1 asterisk asterisk 7.0K Oct 10 19:52 backup.php
-rwxr-xr-x 1 asterisk asterisk  11K Oct 16 16:54 restore.php
ls -lah /var/www/html/admin/modules/fax/bin/
total 12K
drwxrwxr-x 2 asterisk asterisk 4.0K Dec 20 14:13 .
drwxrwxr-x 5 asterisk asterisk 4.0K Dec 20 14:13 ..
-rwxrwxr-x 1 asterisk asterisk 3.0K Dec 20 14:13 fax2mail.php

These files do not exists.

Thank you,

I am running into some issues. I have a box running 1.813.210.58-1 and I want to upgrade it to 2.210.62-2. I created a backup of the running box via the Backup / Restore page. Went to the same page on the new box. Click on Restore, uploaded the file, and nothing. I am not sure what I am doing wrong.


This is exactly what I did but with a difference. I first upgraded my 1.8XX distro to the latest (1.818.210.58) and then got a backup. I am not sure if that will help, but it will help to keep all the FreePBX modules updated before the migration.

What do you mean by “nothing”? Any messages?

PS. Any help on the problematic symlink ? :slight_smile:

Ok so these are my exact steps…

Click on “Backup & Restore” from Admin Drop Down
Click on "Restore"
Click on Browse and Select the file, double click on the file
Click on Go!
I watch the “Uploading” Status go from 0% to 100%
Screen Refreshes and just shows the “Browse to a file to restore from”.

If I select one of the storage locations on the far right of the screen, both show no files, or backup sets. I tested this in Both Chrome and IE.

Odd, I do not have those symlinks except for the fax-process.pl which is pointing to a file that does not exist…

Have you recently updated your Backup & Restore Module?

So this time I decided I would just SCP the file over. And of course that worked. I was able to do the restore and all seems well with 0 errors. I am just not sure why the Manually File upload method does / did not work…

I have always done as you mentioned and scp the .tgz file to the destination server, then restore from there.
Glad to hear that the upgrade from the 1.8 Centos5 distro worked to the current stable.
I have a few machines running 1.812.210.57-1

Staying on topic, a question for the dev team…
Would it be possible, using the above mentioned method, to restore directly to a 2.210.62 install running Asterisk 10? Or is it preferred to restore to 2.210.62 running 1.8 if your source is 1.812.210.57-1?