Upgrade Module from 2.3 to 2.4

I need some testing on an upgrade module that can be installed on FreePBX 2.3 systems and will upgrade you to FreePBX 2.4. I will be publishing this once I have gotten a bit more feedback and make sure there are no issues with it, and once I’ve seen a fair number of the current 2.4 beta testers move to the final release without reports of porblems.

The module can be found here for testing:

I have removed the download location now that the module has been published in the online system. You should pull it from there.

and needs to be manually loaded in FreePBX either with Module Admin’s upload ability or by exploding the tarball in your modules directory.

The upgrade process works like this:

  1. You install the module
  2. You choose the 2.4 Upgrade Tool now in your left navigation bar
  3. You click on the upgrade button and confirm the upgrade
  4. You read the instructions (rtfm)
  5. They tell you to go to module admin and choose to upgrade only Framework, you do that
  6. They then tell you to upgrade everything else, you do that
  7. They have already told you to NOT press the reload bar until you have completed the previous step, so you do that now
  8. You are now done
The process is fairly straight forward but you do have to run through all the steps. In the early testing, the reload bar would come up as usual after loading framework and as expected, people would press it which would result in errors because core had not been upgraded yet. Now the reload bar should not even come up but we left in the warnings in the instructions just in case. The other mistake people make is to press upgrade all as the first step, which results in an error from module admin because many of the modules depend on Framework being upgraded first. So you have to follow the order of the instructions. (Some day, hopefully next milestone, we will build in the smarts to Module Admin to see the dependencies are also being included in the install request and not complain, but it is not there now and it turns out that there are a lot of complexities in doing that which we won't go into here).

Anyhow - your testing this module before we publish it would be very appreciated. You can do it on a vmware system or real system, we just need feedback that it is working as it should so we don’t push it out to the masses broken.

Thanks - please reply to this thread with either success or problem reports testing this.

After uploading the upgrade module, I followed the simple 4 step process and everything took right off.

I only had one warning type of message. PHPAGI Config could not be installed, because I didn’t have Module Asterisk API installed. So I installed that, and that went away.

I just tested everything, and it all appears to be working. Very smooth transition.


Like butter.
All is well.


I followed the instructions and it worked fine - no problems here


to the three of you who replied, thanks so much. to the dozens of you who have downloaded the module but not given any feedback, please do so as we would like the confidence factor before unleashing it to the world. Thanks for the VERY small effort of just reporting back how it went.

No problems with the upgrade all. So far everything works great. Thanks very much!!

I performed two upgrades.

Both were trixbox 2.2.4 installs (started life as FreePBX 2.2.3, upgraded to 2.3.1). These were both fairly recent installs.

I used the “update module” process on one and the “Upgrading Your System” process on the other.

They both worked flawlessly, without even so much as a warning.

I would think that the upgrade module should remove itself from the /modules/ directory though rather than requiring you to do it by hand (it sits in the modules list and says “[color=#FF0000]Not Installed (Locally available)[/color]”).

That’s the only complaint I could come up with! :wink:

Nice work.

  • Darrin

P.S. - I could try the upgrade against the 2.2.3 build as well if that would be useful. I’ve got a diskimage of a post-install trixbox 2.2.4 that I can easily bring up in a VM…

you wanted feedback.

Ok first off the link in the description for “get help for 2.3 to 2.4 upgrade tool” does not produce a valid page… (yea I know work in progress, but you asked)…
Create a new step 3a for all the slow people, it should say once you have applied the changes “LOOK for the 2.4 Upgrade tool button on your left, chick and follow directions”

When you have completed the process and clicked on the red bar, the 2.4 upgrade tool button was still present. I clicked on it, it disapeared, but I again had the red bar to click on.

other then that it upgraded from 2.3 nice and easy…

thanks - feel free to try the upgrade from 2.2 it would be really interesting to see how that worked. As far as removing itself completely it is suppose to as soon as it sees that framework and core are at 2.4.0 or beyond. The most likely reason that it did not remove itself and shows locally available would be because it may not have been loaded in the module directory as user asterisk, that, or a bug …

thanks for the details. I guess I should put something in that link and had completely forgotten about the help. I’ll look at making a book page with the upgrade instructions so that the help links or top tab provide the same upgrade instructions. As far as step 3a - I debated that. The only reason I have the additional information on the Upgrade Module screen if you navigate there part way is so that people know where they are. In reality, it is simply:

  1. press the button
  2. go to Module Admin and download Framework
  3. download the rest
  4. press reload

and all should be done… so telling them to go back, hmm…

I’m getting

Warning: fopen(/etc/asterisk/musiconhold_additional.conf) [function.fopen]: failed to open stream: Permission denied in /var/www/admin/modules/music/install.php on line 21

Warning: fwrite(): supplied argument is not a valid stream resource in /var/www/admin/modules/music/install.php on line 23
Cannot write to file ()

when trying to upgrade moh after upgrade to 2.4

that would not have anything to do with the upgrade or upgrade module. Looks like you may have permission problems on your config file or your music directory.

Upgrade went just dandy. Tried to mess up the upgrade and would not let me.

glad to hear all the good feedback. Since we’ve published it last night we’ve seen about 400 upgrades, so given the silence I think all is well. And as mentioned, you can just check for online updates on 2.3 now, no need to download it manually.


I’v tryed to upgrade the machine… but after clicked on the UPGRADE button and confirmed…
nothing changed in the module admin, no new update avaible for the Framework :frowning:

What I’v to check?
Thank you,
Best Regards

----------------- It’s show :
FreePBX Base Version: 2.4.0alpha0
FreePBX Framework Version:
FreePBX Core Version:


Ok just rebooted the PBX and it have showed the new updates :slight_smile:

Just a question… I got those error during the framework update:
error copying framework files:
‘cp -rf’ from src: ‘/var/www/html/admin/modules/framework/htdocs/*’ to dst: ‘/var/www/html’…details follow
cp: cannot create directory /var/www/html/_asterisk': Permission denied cp: cannot create directory/var/www/html/recordings’: Permission denied

I’v fixed the permission, but what was wrong? how can I fix it manually?
Thank you,
Best Regards


I got noticed the CUSTOM APP as disappared :expressionless: Why ?

Thank you,
Best Regards

I had the issue mentioned in this thread:


I didn’t reboot. I grabbed the full tarball and proceeded with success.


I upgraded my trixbox 2.4 (freepbx 2.3) using the upgrade module and all went fine.
I had a trunk with a SIP provider and before upgrade i was able to list the trunk with the command sip show inuse.

Now this command only shows sip extensions that are defined locally. The trunk is not there anymore…!


I most likely added the module as root, which would explain why it didn’t remove itself. That makes sense.

I tried to upgrade a production box today from 2.3.1 (same setup as the last two I upgraded) to 2.4 using the now-online update module, but I had the same issue that I’m seeing posted elsewhere - namely that after clicking the Update button and going back to the modules page to “check for updates online”, the freepbx framework module did not show an available update for 2.4. Since this was a production box and I didn’t want to leave it that way, I went ahead and applied the tar file upgrade method instead, and everything was smooth sailing after that. Also, I noticed that the “upgrade module” did indeed remove itself once the upgrade to 2.4 was complete.

  • Darrin

The only thing that changed going from 2.3. to 2.4 with trunks is to retain the order of settings with your trunks, in the past, they were resorted (reverse alphabetically iirc) which resulted in some problems corner case problems. So that is one possible place to look. The other common issue is people either adding settings to ‘freepbx owned’ configuration files or settings placed in the wrong files that were working by accident previously.

All seemed to go well I followed the instructions to the T. After the install my inbound routing/DID’s would not route the call from the group to the ext. I could not call from ext to ext my outbound routing does work. When I call from ext to ext I get fast busy and when I call my DID I just get sent right to vmail. The server is sending back a sip message error 603 declined from ext to ext. Any ideas…
Thanks for your help.