Upgrade gone bad: PBXact "framework 13.0.197.8 | Disabled; Pending upgrade to 14.0.13.6"


#1

After running sysadmin_update_system the web GUI broke. It looks like some PHP code was updated and requires PHP 5.4 but the system has only PHP 5.3. I ran:

On login in a shell it gives:

[Exception]
Unable to locate the FreePBX BMO Class 'Userman’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install userman 2) fwconsole ma enable userman

I ran:

fwconsole ma install userman --force

Updating tables userman_users, userman_users_settings, userman_groups, userman_groups_settings, userman_directories…Done
PHP Parse error: syntax error, unexpected ‘[’ in /var/www/html/admin/modules/userman/vendor/illuminate/support/helpers.php on line 359
Whoops\Exception\ErrorException: syntax error, unexpected ‘[’ in file /var/www/html/admin/modules/userman/vendor/illuminate/support/helpers.php on line 359
Stack trace:

  1. () /var/www/html/admin/modules/userman/vendor/illuminate/support/helpers.php:359

The offending line of code is “$result = []” and as far as I can tell, that syntax was deprecated with PHP 5.4. The system is at PHP 5.3.

amportal a ma list | grep framework

| framework | 13.0.197.8 | Disabled; Pending upgrade to 14.0.13.6 | GPLv2+ |

cat /etc/redhat-release

SHMZ release 6.6 (Final)

[edit]

cat /etc/schmooze/pbx-version

10.13.66-22

Regards,
David Koski


(Itzik) #2

Try running

yum update

#3

There are no updates with yum but “fwconsole ma installall” did the trick. Go figure.
David


(Marbled) #4

Hi,

yum update packages, could range from OS ones to application one.

For example, Asterisk is updated that way…

fwconsole ma is FreePBX’s module admin, it can, amongst others, update FreePBX modules…

Have a nice day,

Nick