Upgrade from 5.211.65 to 6.12.65

After I upgraded from 5.211.65 to 6.12.65 using the System Admin Pro module it shows that I am still running 2.11. When I Check Online in the module admin I show vulnerable on FreePBX ARI Framework and FreePBX Framework. ARI says it requires 12.0.5, but the only action I can choose is to reinstall For Framework is shows I need 12.0.1alpha22, but shows all I can do is reinstall
If I try to run the FreePBX Upgrader install is comes back with "A FreePBX version below 12.0alpha1 is required, you have 12.0.0alpha1.

I have tried a few times (I am in a virtual environment). I have tried manually running the .100 script and get the same result.

I have been reading through the forums and wiki and can’t see what I am missing on this update. Any help is appreciated.

Thank you,

from the cli run

amportal a ma download framework
amportal a ma install framework
amportal a ma download core
amportal a ma install core

Thank you for your reply. I have run those commands.
Module framework successfully downloaded
Module framework successfully installed

Module core successfully downloaded
Module core successfully installed

Both installations had the following error.
chattr: Operation not supported while reading flags on /var/www/html/cxpanel
chattr: Operation not supported while reading flags on /var/www/html/isymphony
chattr: Operation not supported while reading flags on /var/www/html/wcb.php

After the above, the module admin it still shows that I have the same vulnerability with no updated versions to install and on the Status page it shows FreePBX is licensed under the GPL

PBX-Version shows.

Thank you,

What version of framework do you have now

FreePBX ARI Framework
FreePBX Framework

Something is weird here. Firstly the latest version of Framework for 2.11 is not 39. I dont know why you have 39. Secondly you are stuck on the 2.11 track still, I just ran the same commands against a system already on 12 and it worked correctly.

The weirdest part is that you aren’t even updating 2.11.

I would clear everything out of “/var/www/html/admin/modules/_cache” then try to redownload framework and install. You should at least be on by this point.

If that doesnt work then I hope you have backups.

I really appreciate your reply. I deleted everything in the cache folder (framework wasn’t in there) and re-ran the 4 commands you gave me.

I can roll back to the previous track, and I have done that several times at this point, but all roads lead back to where I am now that I have tried.
It’s possible I am missing something, but my understanding is that running the .100 in the 5 track would get me where I need to be.
Is there something I can try pre-running that script to have a successful update?

I am not even overly concerned about rebuilding the box, however, I have several boxes to update and want to get the process down before I start the rest. Not all of them are virtual like this one is, so it will be nice to know that if I run into the same issue I have a path to go, without rebuilding.


I am going to be working on this more next week. Is there a document that explains the upgrade process to Freepbx 12? I searched foe one can’t find anything that would indicate I would do anything other than run the .100 procedure in the 5 track.