Upgrade from 15 to 16 Failed

Hello, looking for some help. I tried to upgrade a current freePBX 15 system to 16 and it failed. I’m not sure why and any insight as to what went wrong would be great.

I followed this guide and the upgradecheck command checked out OK: Things to be aware of for a successful FreePBX 15 to 16 upgrade - FreePBX / Installation / Upgrade - FreePBX Community Forums

Here is a Pastebin of the log just before it failed. If someone needs/wants, I can post the full log.: Installed: freepbx16.x86_64 0:16.1-1.sng7 - Pastebin.com

freePBX version: 15.0.23
freePBX upgrader tool version:15.0.32
All modules and system updates are up to date.

I do have a slightly related question…prior to backup, I cloned this VM in case the upgrade failed. Since it failed, I had to use the cloned VM to get everything running again. Doing so caused me to exhaust my Zend Resets. I have contacted support to see about adding more. My question is, if I used a snapshot instead of cloning, will that have used up a Zend Reset? I want to attempt the upgrade again, but I do not want to keep contacting support about Zend Resets in case the upgrade fails again. I am thinking of just setting up a brand new VM with 16 and just restoring from backup. I know that will use a Zend Reset but at least I know it will work.

Any help would be much appreciated! Mods, if I need to break this up into 2 different topics/posts, please let me know and I will do that.

Hi @davidi

Looks like your mysql server is not running properly. Please ensure your sql server is running fine before you start the upgrade process. You can use “fwconsole m” to confirm sql is fine to see if you can get into the mysql prompt.

PDOException: SQLSTATE[HY000] [2002] No such file or directory in file /var/www/html/admin/libraries/BMO/Database.class.php on line 144

Stack trace:

  1. Exception->() /var/www/html/admin/libraries/utility.functions.php:120

  2. die_freepbx() /var/www/html/admin/libraries/BMO/Database.class.php:149

Hi @kgupta I just tried what you suggested and I can get to the MySQL prompt. I attached a screenshot.

Now if you try to do upgrade from this machine then still do you see the same upgrade errors ?

Hi @kgupta To answer your question no, I have not. With that said, this is a cloned VM, so in theory, it will fail just like the VM it was cloned from.

I cannot try to upgrade this system right now because it is in the middle of the workday and my boss would not be too happy with me if I took the phone system down right now lol

Also, I am out of Zend Resets as well, so I am very hesitant to try another upgrade without a solid plan in place. If I create a snapshot, try the upgrade and if it fails, with that use a Zend Reset if rollback to the snapshot? Since, I can’t try this till after hours, I can’t afford to have this machine not activated in case it fails again. How would you propose I move forward? I would love to try another upgrade but not if it’s going to mess up my current activation.

Quick update. I created a new VM, installed FreePBX 16 & restored from backup. I called Sangoma support and they helped me with a Zend Reset. This was a couple of days after I initially posted this. I figured I would update this post for anyone who comes across it in the future. FreePBX 16 has been running smooth so far.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.