Upgrade from 11 TO 12 not working


#1


CentOS 6.8 / FREEPBX 2.11 / Asterisk 11.23

I ran the 2.11 to 12 upgrade tool and managed to get the framework upgraded - I then continued to upgrade the core module and I am getting the error below

Error(s) downloading core:

File Integrity failed for /var/www/html/admin/modules/_cache/core-12.0.46.tgz.gpg - aborting (GPG Verify File check failed).

I tried all the suggestion online re refreshing the gpg keys as “asterisk” and “root” users but cant get beyond this point - Any help with be greatly appreciated !


(Itzik) #2

Did you try this?

https://wiki.freepbx.org/display/FOP/Manually+Upgrading+the+FreePBX+GUI#ManuallyUpgradingtheFreePBXGUI-Upgradingto2.10,2.11or12.0

If it doesn’t work you might want to try to use the conversation tool. home2.freepbx.org


#3

Thank you for your reply - Yes i did try manual command line upgrade and I am getting the same error -

Re "home2.freepbx.org - moving to distro version is not an option for me .


(Tom Ray) #4

Then you’re rebuilding from scratch. The old GPG server(s) where poisoned. Those checks will fail. This was mentioned in tickets and posts previously.

Also v11 and v12 are EOL. So getting support to fix this issue is going to be a big PITA.


#5

Cheers Tom - I had a feeling that was going to be the answer !!!


(Itzik) #6

If you have extra time, you can try to upgrade to 13.


(Dave Burgess) #7

The problem is that all of the GPG keys are trash now, so none of the “other than Distro” upgrade paths are going to work reliably.

This is one of those places where the in-place upgrade-by-hand just isn’t going to get you where you want to go.


(system) closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.