Upgrade FreePBX Framework Issue

Hey guys, so I’m getting an error of “Downloading framework Error(s) downloading framework:
Error opening /var/www/html/admin/modules/_cache/framework- for writing” When I try and update to fix the recent vulnerability.

The problem seems to be addressed here: http://git.freepbx.org/projects/FREEPBX/repos/framework/commits/6f09a237675957944fe9202c297032e3aaa48bcd#install_amp

I was able to find and fix the freepbx_conf.class.php file, but I can’t figure out what file is being referenced by “install_amp”

If anyone can point me to where that file is located I would greatly appreciate it. Thanks!


install_amp is not run during the upgrade process so I think you are slightly confused. Are you running install amp? Your initial part of this message makes it seem like you are trying to upgrade through the GUI but then you jump to talking about install_amp

Thanks for the quick reply. I am definitely confused here. You are correct, I was trying to upgrade through the GUI and was getting that error message, I did some research on what causes that error and it lead me to the solution I linked to. I have no done any commands through command prompt.

If you would be so kind as to explain how I can upgrade, or fix the bug I’m encountering I would greatly appreciate it.

Yeah, I am getting this error as well. Here is the error text.

Error opening /var/www/html/admin/modules/_cache/framework- for writing

I am trying to update the security patch. We got hacked I think and the admin password was changed, lost access so had to take down the voip system and switch providers.

EEk. If anyone has solved this one, please let me know. [email protected]


I have a feeling that iSymphony allowed the security breach. I was looking at all the data that it exposes on the admin console PRIOR to logging in to authenticate. Names, numbers, emails.

maybe I set it up incorrectly, so I disabled it for now.

We had the CENTOS install updated via yum update.

I cannot upgrade any modules via the FreePBX GUI.

I get this message with any attempt in Module Admin:

Please wait while module actions are performed

Downloading announcement Error(s) downloading announcement:
Error opening /var/www/html/admin/modules/_cache/announcement- for writing

kind regards
[email protected]

Webmechnic is this a FreePBX distro?

yes. nothing updates. It all started yesterday when I could not log in to the ADMIN. We recovered the password and noticed there was a security patch. Tried to install it, but fail to write (error message above) I tried other updates. All error from the GUI installer module_admin with the same write error.

Is your disk full? use df -h to check