Upgrade Freepbx 13 to 14 Technical limitations prevent 6 to 7

how do I actually do the upgrade?


Please use the Home2FreePBX tool to migrate your settings to a new machine.


can’t we just install a Freepbx14 VM and restore a full backup to it? What do we do about our licenses? I have upgrade several other boxes no issues that were not on hyperV, what are the issues with it? The migration tool doesn’t seem like it migrates all the settings like CDR’s for example which we need.

How does Commercial modules get transferred?

No. Backup/restore MUST have matching major versions.


So either way we need to create a new VM and use that tool? Then if we want the CDR, we use the MYSQL commands?

what about the commercial modules? Endpoint, sysadmin. How do we transfer the licenses?


Thanks. All those worked but none of the steps migrated my voicemails and all the extensions have it disabled. I thought it was supposed to migrate that as well? We record calls as well I need to make sure all data is there as well.

Do I need to migrate the commercial modules first? I noticed I lost all my settings there as well. Host name, email settings, but it’s not licensed yet.

Both are known issues:

You must manually sync the files from /var/spool/asterisk/voicemail from the old to new. See the note at the end ticket 14693 for a work around to migrate config.

after this , what else am I missing? Hopefully all other settings have moved?

You will probably have to manually copy any custom system recordings (/var/lib/asterisk/sounds/en/custom/), and if you use the commercial Endpoint Manager you will have to re-configure it manually on the new system.

The only thing I noticed is it didn’t migrate the SIP Settings Page

The advanced setting are also not pulled over. Where are the configs for that? Is there no way of backing up endpoint manager configs and restoring? I’m trying to make this so things just work. The upgrade on other systems just worked for example and nothing was lost.

What is the proper method of syncing the VM. I tried copying it with WinSCP. It doesn’t copy the symbolic links, which causes more errors on the VM tab when trying to make changes. Exact error : symlink() permission denied

I’ve never noticed this before, but if so, should probably have a ticket.

EPM allows both templates and extension mappings to be exported to csv from the old and imported on the new. I have had limited success importing templates from an earlier version so usually re-create manually. There is already a ticket requesting EPM be included in the conversion.

There is no proper way to do this, but I use rsync which will work fine provided one system can reach the other via ssh:

rsync -aP <source> <destination>

where the source and/or destination takes the forms:

[email protected]<IPAddress>:/var/spool/asterisk/voicemail/

depending on whether the folder is local or remote. Same method works for system recordings, call recordings, etc. by changing the folders.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.