Upgrade Error

I am upgrading from the terminal with the distro-upgrade and ran into the following error in /var/log/sngupdate log:

######### Starting setup upgrade on Fri Jun 28 10:32:55 EDT 2019 #########
######### Creating upgrade repofile #########
######### Installing needed packages #########
######### Running preupgrade to inventory running system #########
Generating simply styled report due to the limitations of the installed OpenSCAP
More than one module set is detected in the default directory (/usr/share/preupgrade).
Available module sets:
RHEL6_7
CentOS6_7
Use option -s to specify which module set should be used.
######### An error occured, please check /var/log/sngupdate #########

Any idea of how to resolve this? It is referencing option -s but I can’t seem to locate how to run this.

Chuck

Hi,

Can you please type ‘ls -lR /var/log/sngupdate’ and paste the results? It may be quite lengthy.

On the distro, you have the option to pipe to pastebin for a sharable url, i.e.:

ls -lR /var/log/sngupdate | pastebin
1 Like

Sorry, when I run that command I get:
-rw-r–r-- 1 root root 1719 Jun 28 10:32 /var/log/sngupdate

If you are looking for what is inside the log file, I provided that in the original post… but here it is again:

######### Starting setup upgrade on Fri Jun 28 10:32:55 EDT 2019 #########
######### Creating upgrade repofile #########
######### Installing needed packages #########
######### Running preupgrade to inventory running system #########
Generating simply styled report due to the limitations of the installed OpenSCAP
More than one module set is detected in the default directory (/usr/share/preupgrade).
Available module sets:
RHEL6_7
CentOS6_7
Use option -s to specify which module set should be used.
######### An error occured, please check /var/log/sngupdate #########

My apologies, what I meant was:

ls -lR /usr/share/preupgrade | pastebin

Can you please run that?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.