Upgrade error on Apply configuration changes

Can’t get past this error when I press the orange bar after an upgrade to 2.8

I tried to redo the upgrade and restart the server and it still hangs. This is a PIAF and I tried the update-scripts and update fixes. Still get this error.

exit: 1
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
Connecting to Asterisk manager interface…OK

Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = amp111
Added to globals: AMPDBENGINE = mysql
Added to globals: AMPDBHOST = localhost
Added to globals: AMPDBNAME = asterisk
Added to globals: AMPDBUSER = asteriskuser
Added to globals: AMPDBPASS = amp109
[FATAL] function: core_routing_getroutenames has been deprecated and removed
[0] => Array
[file] => /var/www/html/admin/modules/core/functions.inc.php
[line] => 5391
[function] => die_freepbx
[args] => Array
[0] => function: core_routing_getroutenames has been deprecated and removed


[1] => Array
        [file] => /var/www/html/admin/modules/routepermissions/functions.inc.php
        [line] => 72
        [function] => core_routing_getroutenames
        [args] => Array


[2] => Array
        [file] => /var/lib/asterisk/bin/retrieve_conf
        [line] => 622
        [function] => routepermissions_hookGet_config
        [args] => Array
                [0] => asterisk



1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

i have the same problem, i removed all 3rd party modules, but, the problem continue, any suggestion ?

please, disable route permissions and try again, this function fix the problem.