Went to the dashboard just now and am told that there are 22 modules to be upgraded. I select them all and click on Process, but I get an error that they require 2.4.0 and I’m running 2.4.0rc1.
that’s that is because several modules depend on 2.4.0 - if you are running rc1, it should let you upgrade all the ones that are not dependent and then just go back and upgrade again.
yeah, the one that needed to be done separately was framework. after that, no problem. thx!
Same problem here, but updating framework seperately stucks at downloading 83% here. Can’t get any further
sounds like you may have a bad php.ini configuration. Bump up your memory and also, make sure your upload limit size is adequate as the default is very small, 2M I think.
Is there going to be an announcement about 2.4?
Fantastic man, It works!
I’ve increased php memory as you suggested (8M to 32M) and now i’m updating available modules.
cosmicwombat - yes there will be an announcement today.
Sam (Yes) - you may want to play it safe and bump up your memory to something a lot higher, try 80MB
Philippe thanks, i’ll try it right away!
The upgrade from rc1 to 2.4 went very well. I did have to delete the prior pbdirectory module in order to get the new one installed- as I was instructed to do during the upgrade process (thanks for your attention to documentation). Smooth sailing so far!
hmm - that’s news to me, why did you have to delete the pbdirectory vs. just upgrading to the new one? If there is something weird going on there we would like to know. There should never be a reason to have to delete a module. What was going on?
From memory, the pbdirectory upgrade (188.8.131.52) downloaded but erred when trying to process, stating it couldn’t remove the older version and pointed to /var/www/html/admin/module/pbdirectory. This was during the upgrade from rc1, and the only issue I had with the upgrade. I realize that I should have uninstalled via freePBX, but I had a SSH window open and removed it by rm -r the pbdirectory. I was then able to re-download and install the new module without issue.
Corrupt permission perhaps?
sounds like you had a problem with your original install from what you are saying. Module Admin always removes the old module after downloading the new one and then move the new one over to the final place so that error should not be related to the upgrade process. thanks.
I did the framework module. Which went well. Then I upgraded the rest and got:
The following modules are disabled because they are broken:
You should go to the module admin page to fix these.
I have left it be if and if you want into the machine (Philippe) email me.
hmm - I just made a change to the pbdirectory as it previously had a “requires” 2.4.0 tag vs. a “depends” tag like the others. I think that may be the reason for the broken module. Hopefully the change will rectify this.
Im newbie on This,
Can you please help me posting the upgrade steps for rc1 to 2.4?
just go to module admin and accept the online updates.
Forget my lat post, the issue solved now.
But, I couldn’t do that. I tried but got an error. So, I uninstalled the module. Seem to go OK. So I tried to download the module and install. This time I got an error about “couldn’t remove module”
I checked and pbdirectory was there and permissions seemed normal. I deleted the folder and the install went though.
Most likely just this box.