Upgrade 12 to 13 Fails with SSL Connect Error

I am running FreePBX on Asterisk 13.7.2 [build from source]

I run the Upgrader tool.
Step 1: "All checks passed. You may now start the upgrade process"
Step 2: Fill in forms
Step 3: Submit returns “Submitting data to servers…Error contacting server: SSL connect error”

The server has internet access although I cannot ping freepbx.org (It resolves but does not respond to ping)

I have seen this in several posts to the community but have not seen any solutions.

What is the path forward here?


Have you logged into the server as ‘root’ and tried a “traceroute freepbx.org” (or whatever IP address you are using) so you can find your network error?

I am not convinced it is a simple network error.

I can ping google, dell and numerous other public sites.

For what its worth, I am also able to update modules etc so I know the server is able to contact the freepbx server that distributes modules and module updates, despite not getting any response from a ping to freepbx.org.

In a 30 hop trace route, I get:

traceroute freepbx.org

traceroute to freepbx.org (, 30 hops max, 60 byte packets
1 ------- hidden for security reason -----
2 ------- hidden for security reason -----
3 ( 0.907 ms 0.915 ms 0.992 ms
4 te0-0-0-1.edge02.clt.peak10.net ( 1.460 ms 1.707 ms 1.742 ms
5 64-128-45-133.static.twtelecom.net ( 1.683 ms 1.682 ms 1.677 ms
6 mke1-ar1-ae21-0.us.twtelecom.net ( 29.659 ms 29.083 ms 29.202 ms
7 ( 30.462 ms 30.478 ms 30.355 ms
8 static. ( 30.914 ms 30.408 ms 30.390 ms
9 * * *
10 * * *
30 ***

I’m not convinced it’s a simple network error either. In fact, I’m reasonably certain it’s going to be a stupid, one-off, hard-to-find-but-easy-to-fix network error.

Start by comparing the IP address you get from other sources to the one on your server. The address could be cached in your local DNS or documented in the /etc/hosts file (as examples) and not be the address you actually need. The fact that you can’t ping or traceroute to it are indicative of some kind of network error - we just don’t know what kind yet.

freepbx.org resolves to

I have tried from the server (in a data center in North Carolina), a workstation in Austin TX and another workstation in Colorado Springs. Each has totally different ISPs, and name servers and all resolve to the same IP address. I cannot ping from any of these locations… so is it simply a matter of the freepbx.org host at not set up to respond to ping requests? To test this hypothesis, from the PBX command line I can issue a “wget https://freepbx.org” and it does in fact retrieve the index.html page at this address.

Just for kicks, I also cannot ping “community.freepbx.org” ( either from any location although I am obviously on this site replying to this thread right now.

I have not opened up the FreePBX php code to verify this but I was under the assumption that the upgrade from 12 to 13 would have been served up by the same server that offers all the module upgrades. Is that a bad assumption? As noted earlier, I am still able to download from the usual modules upgrade server (for example, this morning I downloaded an update to the custom-contexts module without any problems.

At a guess, something is trying to do SSL interception on your network. Either that, or the time on the server is wildly wrong.

Both of those will cause SSL errors.

Time is correct.

There is nothing preventing SSL access to servers on the internet. I can connect to https://www.freepbx.org using curl or telnet (:443) from the command line on the server.

Obviously I am going nowhere with this line of attack on the problem.

Is there a way to manually download and install the upgrade package?